[VB-21185] Html5 Videos won't play



  • Hey, realy would like to give Vivaldi a shot, but sadly i've encoutered a serious problem. Most html5 Videos just won't play, beside some on YouTube. Checking Chrome:gpu shows that hardware acceleration isn't availabe. The Problem doesn't occour in chrome. Tried both 32 bit and 64 bit with the same result. System: Windows 10 64 bit (Anniversary Update installed) Nvidia GeForce GTX 1070 (Most recent drivers)



  • Try the videos on www.quirksmode.org/html5/tests/video.html
    Also check demo.castlabs.com to confirm that DRM is working



  • Same problem here and drm example is the one not working - it worked fine before windows anniversary update.
    Any ideas?



  • @TbGbe:

    Try the videos on www.quirksmode.org/html5/tests/video.html
    Also check demo.castlabs.com to confirm that DRM is working

    on on www.quirksmode.org/html5/tests/video.html:

    • H.264/MP4 doesn't work
    • WebM works
    • Ogg/Theora works

    on demo.castlabs.com:

    • MPEG-DASH, DRM, WebVTT, multi-languagedoesn't work
    • MPEG-DASH, DRM doesn't work
    • Smooth Streaming, unencrypted works
    • Smooth Streaming, DRM works

    chrome://gpu output:

    [Graphics Feature Status
    Canvas: Software only, hardware acceleration unavailable
    Flash: Software only, hardware acceleration unavailable
    Flash Stage3D: Software only, hardware acceleration unavailable
    Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    Compositing: Software only, hardware acceleration unavailable
    Multiple Raster Threads: Unavailable
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Software only, hardware acceleration unavailable
    WebGL: Unavailable
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    disable_discard_framebuffer
    exit_on_context_lost
    scalarize_vec_and_mat_constructor_args
    use_current_program_after_successful_link
    Problems Detected
    GPU process was unable to boot: GPU access is disabled in chrome://settings.
    Disabled Features: all
    Always call glUseProgram after a successful link to avoid a driver bug: 349137
    Applied Workarounds: use_current_program_after_successful_link
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers/code]
    


  • So seems like mp4, h.264 and drm videos won't play. Also scrolling doesn't seems too smooth. But was to be expected without hardware acceleration.



  • Do you have Intel GPU and GeForce on your system?



  • @Gwen-Dragon:

    Do you have Intel GPU and GeForce on your system?

    Yeah, an intel core i7 6700k cpu (which of course brings an onboard gpu), but its a desktop system and only the nvidia one is in use.



  • That is a known bug in Vivaldi which does not activate acceleration with this hardware constellation.
    I have no solution yet.

    Can you disable Intel GPU in Bios?



  • To fix this one: install latest nvidia driver, if you don't use geforce experiance get it here: http://www.guru3d.com/files-details/geforce-372-54-whql-driver-download.html (issue fixed in win10 anniversary here)



  • So i disabled the onboard gpu in the bios and installed the newest nvidia drivers (v.372.54) but it still won't work. Tried out of curiousity if the same issue occours with other chromium forks, but it doesn't. Guess it can't be helped.



  • Hi,

    I had the same problem on one of my machines, with a GTX980M and an intel Core i7-4980HQ (that also has an integrated display adapter, disabled by BIOS on my machine) : no hardware acceleration.
    When looking at the vivaldi://gpu page, I noticed at the bottom (the line about GpuProcessHostUIShim) that the process "had crashed".

    Searching that problem on the internet, it seems the problem comes from Chromium. After fiddling with all Chromium config flags related to the GPU i could find here, I solved it by launching Vivaldi with the –disable-gpu-sandbox flag.
    After that, when going to vivaldi://gpu, most items display as hardware accelerated, and webGL and html5 videos work.
    It seems that Chromium's GPU sandbox and nVidia drivers don't play nice together in this kind of configuration ?

    Anyway, you may try adding this flag to your Vivaldi shortcut, to see if it helps.

    Edit : System is Windows 10 x64, fix still applies to anniversary update.



  • Seems to me that new snapshot 1.3.551.37 doesn't play H.264/MP4 anymore, they worked for me in 1.3 release.
    http://www.quirksmode.org/html5/tests/video.html the video doesn't even appear, webm and ogg work. until yesterday all 3 played fine also in full screen.
    http://www.html5videoplayer.net/html5video/mp4-h-264-video-test/ doesn't play. trying to open the mp4 link the player shows but the play button is grayed immediately, you can still download them with right click+save as of course.
    demo.castlabs.com works

    Edit: found a workaround, after searching more about this in the forum, I noticed it was also discussed here
    https://vivaldi.net/en-US/forum/vivaldi-browser/10807-h-264-mp4-unable-to-be-played-back-due-to-hardware-acceleration-being-disabled
    I tried fiddling with the vivaldi://flags and I've now tested first disabling

    Hardware-accelerated video decode Mac, Windows, Chrome OS
    Hardware-accelerated video decode where available. #disable-accelerated-video-decode
    Disabled / Enabled (DOES NOT MATTER, I TESTED BOTH AND DOESN'T CHANGE ANYTHING, left enabled)

    press Relaunch now button. after Viv restarts mp4 work again. Now close Viv for real, alt-f4, rerun it after assuring it's not in memory. Mp4 do not work again.

    vivaldi://flags, enable/disable again ANY setting, Relaunch Now button.

    Now the mp4 test videos above are showing, also Youtube videos at 60fps seem to work. It was not needed, as said before, in 1.3 stable. Also the setting seems to not be of any relevance,



  • http://www.quirksmode.org/html5/tests/video.html works for me with Snapshot 1.3.551.37 x86 ion Windows 10x64



  • I probably should have done it before posting, but I couldn't restart the PC this morning. After a complete restart everything is fine, in flags I've reset all to default to be sure nothing there was altered.
    H264/MP4 always working at every fresh PC restart and also after closing and reopening Vivaldi. Luckily it seems NOT a bug but something stuck in memory in my PC. :P



  • Well think yourself lucky - because when the advertisers/malvertisers finally adopt it BIG time - you'll wish you had a full-proof way of turning it off! ;)



  • Same problem here,
    win 10 anniversary, gtx970, current drivers.
    No difference between 32/64bit builds or stable/snapshot.

    After failing to play a video, vivaldi:gpu gives me this:

    [11044:11056:0903/132059:ERROR:gpu_video_decode_accelerator.cc(365)] : HW video decode not available for profile 12
    [11044:11056:0903/132108:ERROR:gpu_video_decode_accelerator.cc(365)] : HW video decode not available for profile 11

    I don't have this kind of errors in chrome.



  • Try disabling hardware video decode in vivaldi://flags.
    I had to disable it to allow youtube 60fps videos playing without heavy frame dropping, which doesn't occur with hw video decoding disabled. Seems in Vivaldi hw video decoding is buggy.



  • didn't help, for example here:
    https://www.youtube.com/watch?v=4pFh4xs-vKs
    I think youtube rolled out a new codec/drm and its not fully working



  • Works perfectly for me even at fullscreen 720@60pfs. Sorry, no idea what's wrong in your system.



  • Both embedded (here) and on Youtube that video plays for me. So not a "new codec" problem.
    Win10 and "only" GT 640 card using Vivaldi 1.4.589.2 (Developer Build) (64-bit).


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.