Black screen on Opensuse 13.2



  • Hi, using Vivaldi for 2 days now and work fine so far. Today I got only a black screen after start, top show 2-3 threads as usual. No error messages in terminal. After remove vivaldi directory in ~./config Vivaldi start again. Opensuse 13.2/64 CPU Intel T4200 GPU Intel GN 965 Two questions: 1. Is there a debug mode when I start from terminal? vivaldi --help has no entries. 2. Can you explain the difference between vivaldi and vivaldi-stable binary Thank you for working on "The real Opera 13" Vivaldi, mib EDIT: Please move to Bugtracker or Bug Report sticky if needed.



  • I have exactly the same issue on Gentoo, using nouveau graphics drivers.

    There is a workaround: removing the file```
    ~/.config/vivaldi/Default/Current\ Session

    
    I've got a shell script that I run instead of the binary, something like
    

    #!/bin/sh
    rm $HOME/.config/vivaldi/Default/Current\ Session
    exec /opt/vivaldi/vivaldi-bin



  • Thanks gray, will try when next blacky appears. :)

    Cheers, mib



  • Fedora 21 Workstation x86_64 same problem… :blush:



  • Hello,
    I am having this same issue on Ubuntu 14.04….Vivaldi works for a few times and then will only launch a black screen....
    It starts again and works after deleting "~./config Vivaldi"....

    Processor : 4x AMD Phenom™ II X4 970 Processor
    Operating System : Ubuntu 14.04.1 LTS (Linux-x86_64)
    Ram memory : 11.7 GiB
    Kernel : Linux 3.13.0-34-generic (x86_64)
    Graphics : GeForce 9800 GT/PCIe/SSE2
    NVIDIA Driver Version : 331.113

    I am excited about Vivaldi….I was sad when Opera changed....
    Thank you....


  • Vivaldi Team

    Thanks to all for reporting. Yes, it's a bug and we will try to fix it ASAP.



  • I can confirm this issue on Ubuntu/Lubuntu/BackBox on an HP 2510P with Intel GMA 945 graphics.
    However, this seems to be an issue with all Chrome(ium) based browsers. Certain random pages will cause the screen to black forcing the user to perform a hard shutdown.



  • Just press F11 when you have it. Here on Xubuntu fixes it.



  • @mib2berlin:

    2. Can you explain the difference between vivaldi and vivaldi-stable binary

    they are both elements of a symbolic link chain to /opt/vivaldi/vivaldi

    $ namei $(which vivaldi)
    f: /usr/bin/vivaldi
     d /
     d usr
     d bin
     l vivaldi -> /etc/alternatives/vivaldi
       d /
       d etc
       d alternatives
       l vivaldi -> /usr/bin/vivaldi-stable
         d /
         d usr
         d bin
         l vivaldi-stable -> /opt/vivaldi/vivaldi
           d /
           d opt
           d vivaldi
           - vivaldi
    
    


  • @Shpankov, thanks.
    @Luzandro, had to do my homework berfore post Q. but now all is clear, thanks.

    Cheers, mib



  • New Vivaldi browser user here.

    After an update yesterday, when trying to run browser today I just get a black screen. Tried running from terminal which produces this

    vivaldi-stable
    ATTENTION: default value of option force_s3tc_enable overridden by environment.
    [1720:1720:0131/103602:ERROR:sandbox_linux.cc(301)] InitializeSandbox() called with multiple threads in process gpu-process
    
    


  • I have the same problem on Ubuntu 14.04 (64)

    I've solved:

    Deleting the ~ /.config/Vivaldi folder (with the consequent disadvantage of removing all the settings done up to that point).

    When I open the browser, press the F11 key is displayed full screen and once we press F11 again, the browser works fine in standard window mode (the option that so far seems more comfortable because you do not lose any settings you have made so far).



  • Before deleting the 'Current Session' file, I run this Perl script to extract the URLs from my session to a file in case I want them. If you already have Perl on your system this should just work.

    #!/usr/bin/env perl
    
    use strict;
    use warnings;
    use Regexp::Common qw/ URI /;
    
    while (<>) {
      if ( /($RE{URI})/ ) {
        print $1, "\n" unless $1 eq "http://tab";
      }
    }
    
    

    Run it like this:

    # dump URLs into whatever file you like
    $ extract-urls.pl < Current\ Session > /home/rml/Desktop/urls.txt
    
    


  • Linux mint 17 (KDE) x86_64 same problem after first reboot. After clearing session now work fine



  • Found I've got the same on Ubuntu 14.10.
    Worked out it only happens when the browser is maximised.
    Returned it to just window fill and it starts every time.





  • Hi, using grays method work fine for me, delete > ~/.config/vivaldi/Default/Current\ Session directory.
    No black screen until today.

    Cheers, mib



  • I was experiencing the same bug as well, and these steps in this post does in fact fix it! I hope they fix this bug before they release the final version. And if there was a serious bug like this, then why won't they disable session restoring by default until they can fix this horrendous bug! If that feature isn't disabled by default, or this bug isn't fixed quickly, then alot of people will just go back to opera, firefox, or chrome/chromium!



  • Hi VivaldiBrowserUser, they are not even in Beta status and it need still some time to get it stable/final.
    Have fun to test it and report as many bugs you can get. :)

    Cheers, mib



  • I get the same thing with Ubuntu 14.04. I've just figured that's the sort of thing to expect for an alpha version.

    I just hit Ctrl-N to open a new window, then close the first one.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.