Location not working



  • I'm new to Vivalidi. I note that sites which find my location automatically don't work. Is there an option to turn this on?



  • Normally Vivaldi asks for permission to allow the webpage to read your geolocation. A popdown at right side of address field should appear.
    //EDIT: Fetching the geolocation does only work on pages with https/SSL.

    Which sites do not work for you? Please give us a URL.



  • @ennerdale: thanks for reaching us out. Please copy the following line:

    chrome://settings/content

    in Vivaldi's url bar. Then press enter and scroll down to "Location" in the window. You'll be then able to update the settings as you wish. We inherit these settings from Chromium at the moment so that's why you need to use this path for the moment.

    Please let us know if this tip worked out for you. :)



  • Hi, thanks for your reply. I visited the Chrome settings link and set it to always locate, then restarted Vivaldi.

    When I visit www.bbc.co.uk/news, it no longer locates my local news as it does in Chrome. If I go to the Location Settings page on the BBC site (the full URL of which I can't give you, because only www.bbc.co.uk/news is displayed in the address bar, even though the Vivaldi settings are for full URL), and click "Use my current location", it return the message:

    Please enable Location Services in your device settings or browser

    • which I have.

    Actually the same happens if I try it in Chrome.

    Google maps finds me OK, so maybe this is an issue with the BBC news site.

    Fortunately if I manually set my location, it remembers it for next time.

    Richard


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.