Settings > Bookmarks. Not available



  • It can't select 'Boookmarks' from the settings menu, nor 'Display All'. I don't want to do a complete re-install as I'll lose all my passwords, notes etc - unless there's a way to back them up.


  • Moderator

    @pen-ultimate:

    It can't select 'Boookmarks' from the settings menu, nor 'Display All'.

    I don't want to do a complete re-install as I'll lose all my passwords, notes etc - unless there's a way to back them up.

    Do you have any extensions installed?



  • If you type:
    vivaldi://settings/
    in the address bar, does that work? I mean, are those options available then?



  • This has had LOTS of prior discussion, including: https://vivaldi.net/en-US/teamblog/118-snapshot-1-2-490-27-closing-in-on-a-1-2-stable-release , from which:

    3Phase Sunday, May 29 2016
    Some of the Bookmarks functions malfunctioned
    Vivaldi | Settings | Bookmarks options are not accessible

    After some basic work and testing – Steffi was correct and the Bookmark file does mess up Vivaldi. Thank you very much for the tip and the pointer, Steffi!

    Quick and dirty fix without rebuilding the entire Profile:

    Vivaldi User Profile subdirectory
    Default\Bookmarks 629 KB
    Default\Bookmarks.bak 629 KB

    File | Export Bookmarks...
    bookmarks_5_27_16.html 103 KB (Vivaldi created the filename)

    Close Vivaldi

    Rename Bookmarks and Bookmarks.bak
    Default\Bookmarks.disabled
    Default\Bookmarks.bak.disabled

    Restart Vivaldi

    File | Import Bookmarks and Settings...
    bookmarks_5_27_16.html 103 KB

    Reload the SpeedDial icons then close and restart Vivaldi

    Vivaldi User Profile subdirectory
    Default\Bookmarks 59KB
    Default\Bookmarks.bak 59KB

    The Bookmarks files went from 629 KB to 59 KB
    Vivaldi Bookmark functions work
    Vivaldi | Settings | Bookmarks options are accessible

    Windows 7 / 10 x86 and x64 | All recent Vivaldi x86 and x64 Snapshots

    …....................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.



  • Thanks everyone.

    I tried the 'Quick and dirty fix' but it didn't work so I did a re-install.


  • Moderator

    @pen-ultimate:

    Thanks everyone.

    I tried the 'Quick and dirty fix' but it didn't work so I did a re-install.

    Please describe your "re-install" steps, and let us know if it worked.



  • 1. Saved my bookmarks. File>Export Bookmarks…

    2. Uninstall Vivaldi

    3. Delete - C:\users\username\appdata\local\vivaldi - it's a Windows 10 32bit installation

    4 Re-install Vivaldi - 1.3.519.25 version.

    It took a little while to get all my settings back, not as log as it did with Opera 12.x! Unfortunately I lost all my password and autofill data. But I guess I could have saved that from the local file, but I wasn't sure what was causing the problem so just got rid of it all. The bookmarks file could have been the source of the problem but as that was the only thing that was saved it would have been obvious where the error was.


  • Moderator

    Thank you for this. So while the bookmark file itself may contribute to this problem, it is for sure, in your case, not the problem (you tried exporting, removing, re-importing, and no joy). Yes, you probably could have at least saved log-in data and gotten it back, but just exactly what is doing this is still rather fraught. It's a fairly rare complaint, and is so far only able to be RELIABLY reproduced by installing certain extensions, but then users without those extensions have still reported the problem. SOME of them have fixed it with a profile refresh, involving backing up their bookmark file and replacing it into the new profile. SOME have fixed it by exporting and importing their bookmarks, SOME have not fixed it. It's a puzzle to be sure.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.