Vivaldi Browser will not start - Segmentation fault



  • I've been using Vivaldi without issue, but suddenly it will not start. Seems to do nothing when I try and start it from menu. So, I tried to start it from the terminal and got something called a Segmentation fault. Here is the terminal output: [b][email protected] ~ $ vivaldi Segmentation fault [email protected] ~ $ [/b] Tried reading up on this, but it is over my head. Other browsers work fine as does everything else. Any ideas on what went wrong? Mint 18, Cinnamon, Dell Desktop.



  • I guess I'm not the only one stumped by this question - not a single idea here or on the Mint Linux forums :lol:.

    I wiped out the .config file folder for Vivaldi and restarted. Lost all my settings, but hey, I'm back and running.

    (Edited for clarity)



  • Just FYI, there has been at least one other [recent] Segfault thread, so you might wanna search for & read that … although i vaguely suspect it also might not have ironed out the problem.
    .......................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.



  • Thanks.

    Before I posted my question, I did all the searching I could, and it seems the only guess - and guess is the right word - as to why this happens, is there is an extension that somehow tries to do something out of bounds. That's why I decided to just start again.

    BTW, in case someone else has this problem and finds this thread: Uninstalling and reinstalling Vivialdi will NOT fix it, and does not have to be done. Leave Vivaldi installed. To fix: remove the .config files for Vivaldi. I use Mint, which is based on Ubuntu. To remove the .config files in those distros of Linux, go to the home folder, click on show hidden files in your file manager (Nemo in Mint), find the .config folder, look for Vivaldi in it, then delete the Vivaldi folder. Be aware, you will loose all your settings, and when you start Vivaldi, it will be fresh as if you just installed it.

    Now, I really like Vivaldi and use it, but I also have Slimjet and Chrome on my system that are also based on Chromium like Vivaldi, and they all have the exact same extensions in them. Chrome and Slimjet did not have this issue.


  • Moderator

    Script blockers have been known to prevent Vivaldi from opening.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.