Segmentation fault



  • Greetings, I just updated sqlite3 on my opensuse 13.2 from version 3.8.6 to the latest and now vivaldi segfaults. So I downgraded sqlite3 to previous version but vivaldi is still segfaulting. Nothing else was changed. I tried reinstalling vivaldi but same result. Any suggestions. BTW, I'm using vivaldi 1.2.



  • Disregard. I had a corrupted extension.



  • "vivaldi is still segfaulting" –> pls excuse my ignorance, but what does this mean? What would a Vivaldi "segfault" actually look like? I have seen other occasional posts mentioning it, but have never understood what this concept means, visually.



  • @Steffie:

    "vivaldi is still segfaulting" –> ... What would a Vivaldi "segfault" actually look like? I have seen other occasional posts mentioning it, but have never understood what this concept means, visually.

    You can take a look at this Wikipedia page. I think people talking about it just experience a crash - meaning Vivaldi is suddenly gone. Then they are looking for the reason and find information in the different logs.



  • Thank you. I did research it prior to my post [including seeing that W page], & various sites gave tech descriptions involving code… sadly this mostly went over my head. After all my reading, i still had no idea of what a V segfault would LOOK LIKE, on-screen [eg, maybe i've had these errors before too & never recognised them?]. If the practical outcome of a V segfault is simply that V suddenly vanishes, well, it would be hard for me to miss that… but it hasn't done that to me since the early months in 2015, i think.



  • Modern C++ has many features that make segmentation faults rarer, but of course it allows you to "shoot yourself in the foot" by using bad programming techniques. Normally when you're programming and the code compiles and links fine but the program crashes with a segmentation fault, all you see on the terminal screen are the words "Segmentation fault". This can be changed by adding handlers that catch the error and print something more useful instead.

    Segmentation faults are nearly always caused by a programming mistake. They shouldn't arise from a browser extension that's written in JavaScript or runs in some other internal virtual machine because that indicates that the error is in the browser's code, which means a potential security issue.



  • @Steffie:

    … but it hasn't done that to me since the early months in 2015, i think.

    Agreed! Running Vivaldi on a bunch of Linux distributions based on Red Hat, Arch and Debian I never have seen a segmentation fault. Hopefully I am not that blind! ;)



  • This is slightly hilarious [well, actually not at all]. TWICE today my beloved V [1.3.501.6 (Developer Build) dev (64-bit)] closed unexpectedly on me. Gahhhhhh, the irony, given my previous posts above, teehee. Both times i was NOT using V; it did not have the focus as i was working within an entirely unrelated pgm, at least one of the times actually on a separate virtual desktop (i have 9]. Both times ALL of the V processes were gone from KDE's System Monitor when i checked [in them thar bad olden early 2015 days, when V [i]often crashed (but when i was actually actively using it, unlike today's instances) there were still multiple legacy processes running, which i had to manually kill in order to relaunch V]. I was puzzled, then remembered this thread [again, the irony]. I opened KSystemLog & found this entry mentioning V:

    [316066.816440] traps: Chrome_IOThread[16500] trap invalid opcode ip:55f976db690e sp:7f06318c1770 error:0 in vivaldi-bin[55f9738ed000+6695000]

    It's gobbledegook to me, but i now ask the Wise Heads here… is that suggestive of a legendary Segfault perhaps?

    If it's not a Segfault, then... i'd already noticed all today so far that V is feeling quite sluggish [even typing this results in several lags before my characters appear]. Many websites seem slower to load or refresh than usual, & Autoscroll is suffering many stutters & stalls. I'm beginning to wonder if it might soon be time to again delete the naughty Top Sites file that has given so many of us so many hassles over a long period. Mine's grown to be 102 MB again. I do not currently suspect a repeat instance of damaged/corrupted Bookmarks file, as NONE of the symptoms many of us experienced with that bug earlier, are manifesting for me now.
    …....................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.



  • Hmmm, not good; V just vaporised again, but this time i was indeed actively using it. Before restarting it, but after confirming no legacy running processes, i deleted Top Sites & its journal. I'm not yet going to recreate all my >500 Speeddial thumbnails, for maybe a few hours, to gauge V's stability. That said, this new entry was in the logs:

    [attachment=3913]LogVCrash_001_20160620.png[/attachment]
    Attachments:



  • Oh dear, yet another V-vaporisation, again during active use. Clearly Top Sites now cannot be the root cause. This vanishing also had an accompanying log entry – can anyone pls advise if these look like Segfaults, & if so, what should i do? Following this latest incident i chose to logout of my KDE session & login again, in case it was a system error. If another vaporisation occurs, i would then actually reboot Mint [current uptime only 6d 4h].

    [attachment=3914]LogVCrash_002_20160620.png[/attachment]

    …....................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.
    Attachments:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.