How to stop this domain auto-playing Flash content?



  • [color=#8800ff]I'd really welcome any ideas to solve this pls... How to stop this domain auto-playing? http://www.brisbanetimes.com.au/federal-politics/federal-election-2016/election-2016-malcolm-turnbull-says-i-havent-changed--one-iota-20160609-gpfqpa.html That page is only one example... [i]all[/i] pages at that domain misbehave this way, & i really dislike it. I assume the site changed something internally, coz up to several months ago i could/did successfully stop the auto-play simply by the easy default of [i]vivaldi://settings/content - Plugins - Let me choose when to run plugin content.[/i] ... which allowed me to then choose if i wanted to play an individual page's content by right-clicking on it. Since [something] changed, my choices are restricted, & inferior. Nowadays i have to untick the box at [i]chrome://plugins/ - Adobe Flash Player - Always allowed to run[/i]. Benefit = it does indeed stop all those pages' annoying auto-play. Disadvantages = 1. if i do want to manually play a specific page, simply right-clicking to activate the plugin now only half-works; the audio plays, but not the video, so i have to return to the Plugins page & tick that box again; 2. one of my Pinned Tabs is http://doublej.net.au/playlist, from which i like to livestream music all day, but this site relies on Flash Player remaining enabled [which thence makes all new tabs opened from the target domain liable to the damn autoplay again]. I do realise this is not a narrow Vivaldi problem; my other chromium-browsers also suffer it. So far i've not even found an extension that reliably helps here. PS - I posted this under Linux, only coz currently i feel too lazy & sluggish to fire up my Win10 VM & test there. If anyone replies that this is cross-platform, i'll edit & change. PPS - Pls don't suggest i stop using Flash [pepperflash]; given these domains are in my frequently-visited-daily list, that's not a productive suggestion. I have actually already written to the ABC music site, btw, asking them to move away from Flash; they would like to, but apparently it's not so easy for them to achieve. ....................................................................................... My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.[/color]



  • UPDATE.

    Least-worst compromise found so far:
    1. untick the box at chrome://plugins/ - Adobe Flash Player - Always allowed to run.
    2. retain vivaldi://settings/content - Plugins - Let me choose when to run plugin content.
    3. Therein, Whitelist my favourite streaming sites that sadly still rely on Flash.
    4. Every time i wish to manually play a Flash video at that target domain, i need to temporarily re-tick Flash in the Plugins page, then remember to untick it afterwards. Entirely doable, but irritatingly inelegant… this is definitely only a Workaround, not a Solution.

    Note; these prior suggestions do not achieve my objective:
    1. https://vivaldi.net/en-US/forum/vivaldi-browser-for-linux/4541-autoplay-video#33309
    2. https://vivaldi.net/en-US/forum/vivaldi-browser/4512-how-to-block-automatic-flash-movies-from-loading#33191
    3. https://vivaldi.net/en-US/forum/vivaldi-browser/7670-block-video-autoplay#43614
    4. https://vivaldi.net/en-US/forum/vivaldi-browser/11372-flashplayer-whitelist#61657

    PS – oh, rats, i just saw this; VB-17431 "Option to disable autoplay for video and audio" – https://vivaldi.net/en-US/forum/vivaldi-browser/1581-feature-request-disable-multimedia-autoplay-by-default?start=20#59882



  • UPDATE #2.

    Haha, well, this proved ridiculously simple to solve, though entirely unrelated to browser technology per se. I discovered that domain had instituted a policy to forcibly autoplay all videos, for all "casual" visitors. Conversely, anyone who took the time to sign up (i used an anonymous email account to do it] could then go into that domain's account's Settings & turn OFF that pernicious setting. It works a treat; finally i can have my cake & eat it. I can continuously stream my music in the background, open this domain's pages & not be annoyed by the videos autoplaying, but i can still manually play individual ones if i wish. No further need for me to keep visiting & adjusting either of the two internal Vivaldi pages. Yay.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.