Cursor not visible in text fields



  • Sometimes in text fields, the caret is not visible. It is happening right now to me, and it is very annoying, as I don't at what position the chars I am typing are being inserted (and it is even worse when erasing text).



  • I have come across this too. Gmail is a prime suspect. I suspect that it's a known issue.



  • I can confirm this is an issue as well and is frustrating. It's been like this for some time. I doesn't happen always but it happens frequent enough.

    I usually keep my fingers on the keyboard when navigating and filling in fields, which become difficult when there is no visible cursor.

    -Chris



  • Yeah, this is really frustrating when it happens on Gmail. This is the only place that I can confirm that it's happening. It happens frequently using Gmail.


  • Moderator

    The missing cursor sometimes happen on some sites. Unfortunately we Vivaldi testers and even the devs haven't a fix yet.

    But i use switching to an other Vivaldi tab and back (use Ctrl-Tab) to bring back the cursor.



  • My primary e-mail is Gmail and I don't have this problem with the cursor, especially given the fact that I read my e-mail a gazillion times a day and reply even more often. It's true I'm using Vivaldi for a few days only but I so far I've never had this cursor problem.



  • Hey, guys, the problem is still relevant on the last snapshot - in many cases (like in 10% of times) site has no cursor in the text fields until I click on the URL (or switch to another tab) and click back. I blamed extensions at first but disabling them all didn't help.


  • Moderator

    The bug is is known. The developers working are on this bug which is not easily to reproduce on all situations.



  • @Pesala:

    I have come across this too. Gmail is a prime suspect. I suspect that it's a known issue.

    I never had a problem with the cursor on Gmail, so I doubt Gmail is the culprit. Once or twice the blinking cursor disappeared on this forum as well. There's however a flag option (vivaldi://flags or something similar) where you can enable suggested entries upon the first click on an empty box. When I enabled that flag option, the blinking cursor disappeared absolutely everywhere, so I had to disable it. If not touched, this option's state is usually "by default" which I suspect means something like "automatic choice". So for the blinking cursor to return I had to manually select "disabled" for the flag in question and now the blinking cursor DOESN'T disappear even here.



  • So for the blinking cursor to return I had to manually select "disabled" for the flag in question and now the blinking cursor DOESN'T disappear even here.

    Didn't help, unfortunately, cursor didn't stop disappearing every now and then.



  • I can confirm this occurs in gmail very frequently. Actually I've noticed it happens when I attach a document.

    Also quite frequently the gmail site becomes unresponsive (you can't expand anything to reach for example cci etc. Also seems to be related to attachments.


  • Moderator

    Yes, that is a strange bug which does not always occur on every site and not in all situations.
    Sorry to say, i looked into Vivaldi's bug tracker, but the developers were not able catch the bug yet.

    Workaround:
    F8 and Esc
    or
    Tab switching to next and previous
    gives back the visibility focus of cursor



  • @Gwen-Dragon:

    Yes, that is a strange bug which does not always occur on every site and not in all situations.
    Sorry to say, i looked into Vivaldi's bug tracker, but the developers were not able catch the bug yet.

    Workaround:
    F8 and Esc
    or
    Tab switching to next and previous
    gives back the visibility focus of cursor

    it still happens to me with latest 1.4 version and also on top of the disappearing blinking cursor also the bug of blank page situation even happens still it just happened when i tried to login, i pressed login, page went blank



  • Looks like this problem should be fixed in the last snapshot - will be monitoring it.



  • Well, looks like it wasn't. Still having those issues - on some websites the cursor keeps disappearing



  • It disappears after an alt-tab, even while writing in this forum is replicable, for example I had to copy/paste something from another window. The usual f8/esc combo workaround still have to be used =)



  • Yeah, I can confirm that. Simple Alt+Tab is now enough to trigger the issue.



  • Hopefully it's fixed internally



  • Happening also in Gdoc Spreadsheet :-|

    Vivaldi:	1.5.638.3 (Official Build) (64-bit)
    Revision:	4347b6ce788c90e81c0c7e37d76b11e2a86eafeb
    OS:	Windows 
    
    


  • I can confirm this issue, it's extremely annoying, it pops up in Podio, LinkedIn, MediaWiki, you name it

    i can also trigger it with Alt+TAb

    I have only seen this issue within the last 4-5 days, i think it came with one of the resent updates :(


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.