Youtube on Vivaldi 1.2 not working



  • Running 1.2.490.39 (64-bit), and getting an Error message when I try to watch a youtube video (only youtube, not video from other sites). Works when I disable HTML5, but I'd rather fix it that turn it off. Attached the error code below. Attachments: [img]https://forum.vivaldi.net/uploads/attachments/82242/ScreenShot2016-06-06at9.33.32PM.png[/img]


  • Moderator

    Please give us more background information to help you.
    Video URL? Which Windows?

    As i remembered some GPU cards/drivers with 64bit Vivaldi (a Chromium bug) have problems with Hardware acceleration.
    Please try 32bit Vivaldi.



  • I'm having the same issue, in fact, for me, no youtube videos play. I can play them in firefox but not vivaldi. Below is the about from my vivaldi, and I'm running Windows 7 SP1 64bit version. Please let me know what other information I can give to be more helpful.

    Vivaldi	1.2.490.39 () (32-bit)
    Revision	913448ac42b4b8bda5aa5fb7e76cbff365453b40
    OS	Windows 
    Blink	537.36 (@913448ac42b4b8bda5aa5fb7e76cbff365453b40)
    JavaScript	V8 5.1.281.58
    Flash	21.0.0.242
    User Agent	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Vivaldi/1.2.490.39
    Command Line	"C:\Users\jyuan\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --disable-translate --ppapi-flash-path="C:\Program Files (x86)\Google\Chrome\Application\50.0.2661.102\PepperFlash\pepflashplayer.dll" --flag-switches-begin --flag-switches-end
    Executable Path	C:\Users\jyuan\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path	C:\Users\jyuan\AppData\Local\Vivaldi\User Data\Default
    Variations	16e0dd70-3f4a17df
    b3888d8d-afba0f91
    74785582-3f4a17df
    85c66937-3f4a17df
    f1eb96ab-3f4a17df
    775ebbd7-3d47f4f4
    76b48ab8-a2567007
    195ce1b5-d93a0620
    9d315c2-ca7d8d80
    dd4da2fc-3f4a17df
    93731dca-3f4a17df
    1d3ad72e-3f4a17df
    165e16d1-3f4a17df
    64cbdfc2-3f4a17df
    f5dd6118-2f5721af
    f79cb77b-3d47f4f4
    89cd0b4b-33373774
    4ea303a6-3f4a17df
    d5b671a5-3f4a17df
    4117e878-23622c9b
    dbffab5d-f51b51
    30e679f-3f4a17df
    867c4c68-3f4a17df
    d747916f-d747916f
    6844d8aa-669a04e0
    874cf5b5-c6f0e220
    71140742-3f4a17df
    9f0ebdd7-3f4a17df
    a70306ec-3f4a17df
    Compiler	MSVC 2015
    
    

  • Moderator

    Perhaps you dont have a hardware accelerated GPU/graphics vard driver?

    What is show in section "Graphics Feature Status" of vivaldi://gpu ?



  • Below is the Graphics Feature section requested, looks like it is Hardware accelerated. I do have a bunch of things under Problems detected as well.

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    
    

    Problems Detected
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage_faster_than_teximage
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    Disable Direct3D11 on systems with AMD switchable graphics: 451420
    Applied Workarounds: disable_d3d11
    ANGLE crash on glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Direct composition flashes black initially on Win <10: 588588
    Applied Workarounds: disable_direct_composition
    Accelerated rasterization has been disabled, either via about:flags or command line.
    Disabled Features: rasterization
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers


  • Moderator

    For me on Windows 7x64 SP1 Vivaldi 1.2.490.39 (32bit) works on Youtube.

    I remember while testing internal builds on Windwos 7 64bit Vivaldi has got a bug from Chromium code with hardware acceleration; 32bit doesnt have this problem.

    Can you please try 1.2 32bit or 1.3 Latest Snapshot?



  • @jabbajac:

    I'm having the same issue, in fact, for me, no youtube videos play. I can play them in firefox but not vivaldi. Below is the about from my vivaldi, and I'm running Windows 7 SP1 64bit version. Please let me know what other information I can give to be more helpful.

    Vivaldi 1.2.490.39 () (32-bit)
    –ppapi-flash-path="C:\Program Files (x86)\Google\Chrome\Application\50.0.2661.102\PepperFlash\pepflashplayer.dll"

    You are using Vivaldi 32bit ;)
    I also notice the flashplayer is from Chrome - could that be a 64bit version?
    No idea if it would make a difference if you tried the player direct from Adobe downloaded using Vivaldi?
    On my system the player path is:
    ppapi-flash-path="C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_21_0_0_242.dll"



  • @TbGbe how would I go about changing that? I definitely have adobe flash installed on my machine.



  • Just to test, you could add the " –ppapi-flash-path=[folder/dll] " string to the Target field of your Vivaldi desktop icon.
    Note: there are 2 dashes - -

    As I said, this is just a wild guess, no idea if will change anything. But you can always just delete the path afterwards.


  • Moderator

    But, stop…
    Please,Flash is not needed anymore for Youtube.
    Youtube plays fine as HTML5 video player since years.



  • Hmm I just tried that and it just ended up showing both paths so I removed it. It didn't do anything to the flash video to allow it to play either. I think this started to be an issue after a recent update. Hmm this issue is also happening with my chrome browser…but firefox will play it correctly. I'll see if I can find a fix for chrome first and see if that may carry over to vivaldi.



  • So just a bit more information, it's not a flash issue as flash loads on other websites, I can watch Vimeo videos, I can stream music via pandora, it looks to be a pure issue with youtube.



  • @Gwen-Dragon:

    But, stop…
    Please,Flash is not needed anymore for Youtube.
    Youtube plays fine as HTML5 video player since years.

    You're right B)

    I had forgotten it no longer required a preference setting :blush:



  • jabbajac
    What doyou see here - https://www.youtube.com/html5



  • I went to the link and saw that my browser does indeed support html5 and webm video. Funny enough, youtube videos are now working again. I did have to reboot the computer a few times but whatever it was…it's now working. The only two changes I believe is that I'm now using a 32-bit version of vivaldi as opposed to the 64-bit version and I had to reboot a few times.



  • Okay, it's kind of weird actually. If I leave the youtube.com/html5 page open videos load fine, but if I close the page, youtube goes back to spinning loading circle and then eventually tells me there's a playback error.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.