How to turn off: Automatic back at page end



  • Hello, I have a question concerning the newest Vivaldi Release for OSX. When I scroll (with the Apple Mouse) to any page end, the browser automatically goes back. This is very annoying to me and I would like to turn this feature off. I have not been able to reproduce this behavior on other browser like FF or Chrome, so I assume this is a Vivalid thing. How can I turn this off? This is annoying: I needed 3 (!) tries to edit this page, because the page was reloading/going back everything before I could hit the edit button. I am aware people talked about similar things like in https://vivaldi.net/de/forum/vivaldi-browser-for-mac/11334-previous-next-history-gesture-too-sensitive#61906, not sure if that is 100% this issue. Thanks for any help or input. Greetings Timo


  • Moderator

    Do you mean the browser goes back to the previous page in the browser history if you scroll to the end or a page or that it goes back upwards on the page again that you were scrolling down on?

    With "newest Vivaldi release", do you mean the 1.2 stable version or the 1.3.501.6 developer snapshot?

    EDIT: I just saw your edit after posting my reply. Yes, it sounds like the issue in that thread is related to what you are experiencing.



  • Hi,

    wow this is unusable: Vivaldi even went back in browser history/reloaded while I was starting to type this reply and I had to restart typing.

    I am using 1.2.490.39 () (64-Bit).

    And Vivalidi goes back one history I think (not scrolling up or reload).

    Any concrete tips how to turn this off? As a past Opera user I love Vivaldi (I used FF in between 12.x and now). But for single actions I -had- to use another browser because this behavior drove me nuts in Vivaldi. So any tips are appreciated.

    Thx

    Gasgeber


  • Moderator

    I don't have an Apple Magic Mouse (that's the one you have, right? the one with the touch sensitive top surface?), but I am assuming that the issue you are experiencing is the same as the one I experienced with two finger scrolling being too sensitive so you would accidentally trigger history back.

    That issue was fixed recently; I thought it was fixed for the version you are using but maybe it was later. It is definitely no longer present in v1.3.501.6, which is what I am using currently.

    Before it was fixed, my workaround was to change System Preferences->Trackpad->More Gestures->Swipe to "Swipe with three fingers". That gesture is not currently supported by Vivaldi, so you can only use it in other apps, but that also means you can no longer accidentally trigger history back, which I found very annoying, too.

    So, in short, you have two options:

    1. You can switch to using developer snapshots, in which the issue is already fixed. The snapshots sometimes have regressions and are a bit more rough around the edges than the stable builds, but you also get new features/fixes faster.
    2. You can try to temporarily either deactivate the swipe gesture or change it to a three finger swipe. As I said, I don't have a Magic Mouse, but I would be surprised if the settings would not be very similar to the ones for trackpads. When the next stable version of Vivaldi is released, which should contain the fix, you can go back to your current settings.

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.