Four Vivaldi-zombi proceses after it had been stopped?



  • [url=http://5cm.ru/view/i7/zn8a.png][img]http://i7.5cm.ru/t/zn8a.png[/img][/url] I have 4 vivaldi-bin processes running all the time after browser was stopped? Is your browser a spyware? I don't like anything running in my system without permission. Another question how to stop any updates totally, where is this option located in the settings?


  • Moderator

    The browser is not spyware. There are some bugs will all processes shutting down on some systems. My system, for instance, is unaffected.

    For now, to avoid updates, simply close the notification window when you see it. Don't click through the necessary steps to make an update happen.



  • To kill all lingering processes, you can type killall vivaldi-bin in a terminal.

    The Vivaldi .deb and .rpm packages also install the repositories that will update the browser. If you disable the repository from your package manager you won't get updates.


  • Moderator

    Oh. Right. Linux.

    Kumiponi is right of course. Disable the repos.



  • You dont want programs running?
    Oh, then you should run this in the shell: rm -fr /; reboot


  • Moderator

    @Aalexeey:

    I have 4 vivaldi-bin processes running all the time after browser was stopped …...

    see if helps: uncheck "continue running background apps when Vivaldi is closed"

    chrome://settings/search#System
    


  • Can't find any option like "continue running background apps when Vivaldi is closed". I remember such in Slimjet. And there is no "System" in anywhere.
    The only way to kill them killall -s KILL vivaldi-bin one by one. I have a nice Caja script, but why should I use that just for one of browsers?


  • Moderator

    Lamarca has made a common little goof.

    He input the address into the address bar, ran it, and then copied it from there after making sure it worked.

    Problem: When you do that, the address is changed from chrome:// to vivaldi:// and the latter address doesn't go to the same place.

    So the address to the setting you want is chrome://settings/search#System

    Now I've been terrible and edited his comment without his permission, so that the mistake is no longer there.


  • Moderator

    @Ayespy:

    He input the address into the address bar, ran it, and then copied it from there after making sure it worked.

    yes. that's exactly what i did. thanks for correcting the address. :)



  • chrome://settings/search#Система to be exact! Done. And how can I enter this hiden "opera:config", to check what are there?
    The /etc/cron.daily/vivaldi was deleted too, I have no idea what for and why it should be there!



  • So after some starts and stops this butiful four "unstoppable" zombo-brothers are there again! What is a next step?
    The System is Debian Wheezy MATE Desktop.



  • I fear (like Aalexeey) that is not a problem of running background apps settings. :(

    On my Debian 8 some processes last long after ending Vivaldi, about 1-2 minutes and then all close. Some long cleanup.
    But sometimes remaining zombies are mostly crashed Vivaldi's, i had this with pepperflash or some keyring problems. :(

    My only solution was killall in the shell.



  • So far the same.



  • Hi, it seams you are the only one with zombies since Jun 2016.
    Never had this on my systems.

    Opensuse Leap 42.1 x86_64
    Intel i5 3570K 16 GB RAM
    GTX 760 4 GB /Display card
    GTX 670 2 GB
    Driver 367.44
    Intel opencl_runtime_15.1_x64_5.0.0.57
    1.0.403.20

    Opensuse Leap 42.1 x86_64
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    Vivaldi latest snapshot

    Cheers, mib



  • @lamarca:

    @Aalexeey:

    I have 4 vivaldi-bin processes running all the time after browser was stopped …...

    see if helps: uncheck "continue running background apps when Vivaldi is closed"

    chrome://settings/search#System
    

    worked perfectly, thank you! :-)



  • @ultraviolet:

    see if helps: uncheck "continue running background apps when Vivaldi is closed"

    chrome://settings/search#System
    

    It helps for one or two restart only!



  • Disabling this background option doesn't always help it seems.

    Did you check whether you installed some Chrome extensions?

    I had the Pinterest installed, and most of the time on closing Vivaldi some zombie processes kept running.
    Actually I disabled the Pinterest extension.



  • Hi Aalexeey,

    Quitting the browser by using Ctrl+Q instead of clicking the close button ends all Vivaldi processes. The same might work for you.



  • @hasina:

    Ctrl+Q ends all Vivaldi processes

    No, one only. Other friends are running.



  • After 5 month and many updates no changes, can any body do something about our "feel safe", to not looks like googlo spyware.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.