CPU Usage



  • Vivaldi may take up less memory compared to Chrome, but it does eat up more CPU usage. Not sure if you're looking into working on this, but it would be nice to fix. I'd use it over Chrome.



  • When not loading pages Vivaldi processes show 0% CPU use, with sporadic 1% and 2% CPU use per process, highest I've seen is 5%.

    While loading a page the highest I saw was 40% (for a moment).

    This is an old PC.

    [attachment=3758]s.png[/attachment]
    Attachments:



  • Normal use cpu stays between 8-20%. So not that much.

    If you have an older Vivaldi profile running, try to delete the 2 top site files. Also you can try to deactivate hardware acceleration of the browser as on some machines this can lead to graphic corruption, crashes and also abnormal resource consumption.

    Find it in vivaldi://chrome/settings/search#a and turn it off.



  • Code optimization is definitely needed…
    As of now, I can't use Vivaldi at all on my 'browser' rig - N3150 Celeron/Pentium CPU (basically 4-core Atom)
    When starting V, I get 100% CPU on all four cores, and it takes about 10-20 seconds to start.
    When browsing, pages load very slow, I notice lags even in UI elements showing up.
    Tried all things suggested in this forum, nothing helped.
    Usually I use Opera 39 on this PC and never noticed any lags with it.

    I could understart V being slow if I used dev release, but this is 'official' release I tried... And I am not going to waste 200$+ on a upgrade just for a browser, sorry.



  • Hi Andys, I use a very old dual core laptop as second system with snapshot 1.4.589.2.
    It use 0% CPU with this forum page, one speeddial, Google and help page open.
    It start a bit slower than Chrome but page loading is same speed or faster.
    Several user had the problem with high CPU usage but most can fix with cleaning profile.
    I delete my profile several times since I use Vivaldi (more than a year) and never had problems with high CPU usage, lags or something.
    Can you please add your system specs, Vivaldi version and so forth?

    Cheers, mib



  • @mib2berlin:

    I delete my profile several times since I use Vivaldi (more than a year) and never had problems with high CPU usage, lags or something.

    Thanks! Clearing profile really helped. Though, if this happens with 2-month old profile, I think I should experiment a little - find which files slow down V and make them read-only. I'll give it a try and see how it goes from now on


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.