Bookmarks acting strangely



  • I have recently migrated from Opera to Vivaldi and the difference in performance is amazing so "Thanks" to whoever is responsible for giving a longtime but more and more disillusioned Opera user a new, quick, clean browsing experience. Unfortunately in the last two or three days something has gone wrong. It is now not possible to bookmark any tabs as the "Add Bookmark" tab at the end of the Address bar has stopped functioning as has the "Edit Bookmark" function which appears when a tab has already been bookmarked. Additionally "Ctrl+D", which has served the same function in the past, no longer works. On the Bookmark Bar itself it is impossible to copy and paste any bookmark between different folders. The problems started when I carried out my usual "sudo apt-get update" and "sudo apt-get upgrade" a few days ago and I appeared to get a new version of Vivaldi. I have tried reinstalling both 64 and 32 bit versions of Vivaldi and the Bookmark problem is identical in both. I am using Linux Mint 17.3; Vivaldi 1.2.490.39 () (64-bit); Revision 913448ac42b4b8bda5aa5fb7e76cbff365453b40 Is this a known "bug" with the latest version of Vivaldi and is there a "fix"? Thank you in anticipation of your attention.



  • Welcome to the forum BazP!

    Your problem sounds like your profile might be corrupted.

    You can take a look at this post for the steps to renew your profile.



  • Hi,

    same problem here. The above mentioned workaround did not help….



  • I've tried the workaround three times and none of them were successful although the problems were alleviated provided I didn't import any existing Bookmarks or Tabs. I've individually copied all of the tab addresses to a LibreOffice Writer file so that I can start with another new Profile but I will still be unable, I'm sure, to copy and paste files between folders.

    I shall report back to let you know the progress with bookmarking Tabs when I open another new profile and have copied them all manually from the LibreOffice Writer file.



  • It works with a complete new and fresh profile. But as soon as I copy my files into the new profile, sites can't be bookmarked in the address bar.

    Same problem on both computers here, one with Xubuntu, the other one with Manjaro Linux. The problem occured with version 1.2



  • I've copied all tabs manually from Opera to Vivaldi (another new profile) and now imported the Bookmarks. Exactly the same problem - cannot Bookmark Tabs and cannot copy and paste anything between Bookmark Folders. As the Tabs worked properly before importing the Bookmarks - I could Bookmark them and edit them - I can only assume something is wrong with the way Bookmarks are imported.


  • Moderator

    Some have had success exporting bookmarks, deleting the actual bookmarks file, and then re-importing bookmarks cleanly.



  • Thank you very much for your response, Ayespy, but I have now tried every conceivable way to import my bookmarks, even to the extent of copying and pasting then from the Bookmarks file in Opera into that of Vivaldi - all of which have been successful. Unfortunately I am still left with the problem of not being able to Bookmark any new Tabs, not being able to edit any existing Tabs and not being able to copy and paste any folders or Bookmarks in the Bookmarks sidebar.

    This problem has only manifested itself since the latest update of Vivaldi and did not exist until five or six days ago. Is there any way to go back to the older release of Vivaldi (for Linux) until this matter has been resolved?



  • It's absolutely the same here. And I've just noticed that the speed dial also behaves strangely, nothing happens if something is added. But as I close the speed dial tab and open it again, all changes are visible.



  • To those suffering this genuinely frustrating problem. The way in which you deal with the bookmarks file seems to be critical in the solution. Many of us have found that simply copying the bookmarks file back & forth, does NOT solve the problem. Specifically, many of us found that the process of using Vivaldi's native importer somehow seems to "clean" the bookmarks file such that all your broken bookmark functions work again. Follow this – https://vivaldi.net/en-US/teamblog/118-snapshot-1-2-490-27-closing-in-on-a-1-2-stable-release

    Quick and dirty fix without rebuilding the entire Profile:

    https://vivaldi.net/en-US/teamblog/118-snapshot-1-2-490-27-closing-in-on-a-1-2-stable-release
    3Phase 8 hours ago
    Some of the Bookmarks functions malfunctioned
    Vivaldi | Settings | Bookmarks options are not accessible

    After some basic work and testing – Steffi was correct and the Bookmark file does mess up Vivaldi. Thank you very much for the tip and the pointer, Steffi!

    Quick and dirty fix without rebuilding the entire Profile:

    Vivaldi User Profile subdirectory
    Default\Bookmarks 629 KB
    Default\Bookmarks.bak 629 KB

    File | Export Bookmarks
    bookmarks_5_27_16.html 103 KB (Vivaldi created the filename)

    Close Vivaldi

    Rename Bookmarks and Bookmarks.bak
    Default\Bookmarks.disabled
    Default\Bookmarks.bak.disabled

    Restart Vivaldi

    File | Import Bookmarks and Settings…
    bookmarks_5_27_16.html 103 KB

    Reload the SpeedDial icons then close and restart Vivaldi

    Vivaldi User Profile subdirectory
    Default\Bookmarks 59KB
    Default\Bookmarks.bak 59KB

    The Bookmarks files went from 629 KB to 59 KB
    Vivaldi Bookmark functions work
    Vivaldi | Settings | Bookmarks options are accessible

    Windows 7 / 10 x86 and x64 | All recent Vivaldi x86 and x64 Snapshots



  • Thanks, that helped, but…..



  • No, it's not working satisfying. Just added a bookmark, edited and tried to delete it: Still the same as before.

    I think this happens when one tries to delete a bookmark…..



  • Steffie, the information at the link has definitely brought about an improvement but it isn't perfect yet but that's maybe because I haven't explored every post on the link yet although I have completed the steps that you have reposted here from 3Phase.

    Thanks for your help.



  • I did not switch to Vivaldi to become an expert on work arounds - grin. When I updated a few days ago, the bookmark tab and manually adding bookmarks stopped working. Any attempt to go further, stalled Vivaldi and I had to force quit - yes I am using my beloved MacBook. B)



  • Still not solved. If you delete (try to delete, it does not work) a bookmark, new bookmarks can't be set.



  • It was very remiss of me, I know, but I just wanted to add that my bookmarks are now working perfectly - well apart from a few facilities I would like adding but they are nothing to do with this thread.

    Thank you to whoever resolved the problem many weeks ago. :cheer:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.