No lastpass, no Vivaldi for me



  • Every week, I faithfully check the team blog and download the latest build in the hope of finding that Lastpass is working. Unfortunately, it still isn't -- as has been thoroughly documented in other threads. I'm aware that there is a priority in building new capabilities to attract new users as opposed to fixing basic stuff like making certain extensions work with Vivaldi. Recently the team has incorporated a impressive list of new features that will definitely generate buzz and new users. But what's the point of attracting new users if once they try Vivaldi they find that an extension they depend on doesn't work? In my case, I will continue to monitor progress with Lastpass and hope that one day I will be able to make Vivaldi my daily driver. Congratulations to the team on an excellent product.



  • In my Vivaldi (1.2), Lastpass works.



  • Vivaldi build 1.3.501.6 LastPass works, but i have issues with login.



  • is and has been working for me on Apple MacBook. Could it be that you need to update Last Pass?



  • LastPass is my most important add on, too. BUT IT WORKS, I'm using Vivaldi for months now, and it always worked, with all versions.



  • LastPass doesn't work for me either. I need to login on the lastpass website and then I can use the extension. Whenever I try to login through the extension it takes ages for the login to process. Doing it through the website is faster and works.

    I am on the latest snapshot 1.3. LastPass has this issue for me since v1.



  • Works for me, and has for some time, on the Windows version of Vivaldi. Are those encountering problems using Mac or Linux, perhaps?



  • It works for me in version 1.3.501.6. Only the login is taking some seconds to proceed. But then it works for me like a charm.



  • Actually signed up to say that, while LastPass works, it certainly takes an absurd amount of time to login through the extension.

    Hoping this gets addressed soon.

    Vivaldi 1.2.490.39 () (64-bit)



  • The extension LastPass works here, but with problems when performing login. It's very incovenient having to login in the website

    Here: 1.4.589.11 (Stable channel) 64 bits



  • Same here; LastPass will not fill form fields.
    I have to manually get the creds from LastPass and paste them.
    This is a blocker to me using Vivaldi full time.



  • The latest Vivaldi snapshot contains a fix for the long loading times associated with logging into LastPass.



  • @purgatori:

    The latest Vivaldi snapshot contains a fix for the long loading times associated with logging into LastPass.

    Yes! I was using the stable build but now I upgraded to version 1.5.604.4 and the long loading time after logging into LastPass is gone. Perfect. Thanks for the information. :)



  • If you still have the problem with the long loading times (e.g. because you use the stable build of Vivaldi) do this:

    Open the Lastpass menu -> More options -> About Lastpass

    Allow and activate the binary extension for Lastpass. Now everything works perfectly.



  • Thank you! This worked perfectly! (Except my button said something about enabling Native Messaging.) Now I need to figure out why XMarks is so slow.



  • @dakira WOW, this has been annoying me for seven months.. Thanks!



  • I agree that not having Lastpass would be a showstopper. However it seems to work fine for me (Windows 10, latest stable channel). I don't have the binary component enabled and I don't see any delay in logging in.



  • I'm using Vivaldi 1.6.689.46 (Stable channel) (64-bit) on openSUSE Linux.

    Clicking on the LastPass extension's icon in the toolbar brings up a tiny (about 1 character x 1 character in size) beginnings of a dialog, more like an upside down hottip.

    There is no access to logging into LastPass or access to any of its menu items.

    Attempts to access LastPass' options from the extension manager goes to a blank page (chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/tabDialog.html?dialog=preferences&cmd=open). When installing the extension, it went to a different extension: url that normally allows new users to register. It too was a blank page.

    This makes Vivaldi unusable for me for anything but casual browsing, which is a shame because it beats other browsers hands down.

    Anyone else having problems using LastPass on Linux?

    Thanks!



  • @macobas So far so good here. Vivaldi 1.6.689. Boghi Linux 2.62?/Ubuntu 14. Just throwing that out therefor whoever. FWIW, I had to uninstall my previous attempt to use Vivaldi as it was unstable and tended to lock up/became unresponsive if left unattended for any length of time. All it took was a version change. Hopefully they'll get things tightened up for you as well. I'm still sorting out ad blockers..


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.