Fonts problem with disabled DirectWrite



  • This is happening since 1.2 update, everything was fine on 1.1. Fonts are randomly becoming completely non-antialiased, you can fix it by closing page and opening it again, simple reloading doesn't help. Happens more often if you open links in the background tab by clicking middle mouse button. Something like this: https://i.imgur.com/U2eqLVi.png Same issue is found here: https://vivaldi.net/en-US/teamblog/120-vivaldi-1-2-with-mouse-gestures https://i.imgur.com/W7zkLEG.png



  • I confirm this. You may ask why did I disable it in the first place — that's because it makes fonts too blurry for my taste.



  • if you disable DirectWrite the font rendering will not work correctly, that is a problem in Firefox, Chrome and Opera, too.
    But this Windows problem cant be fixed by Vivaldi devs.



  • You are wrong. Everything is fine in chrome/firefox/opera (i use them all with directwrite disabled), this problem exists only in Vivaldi.



  • Happens to everyone who uses the browser without DirectWrite. I really hope a fix is released it's serious enough to make the browser unusable if you regularly open tabs in the backgrounds. Pretty much 90% of the ones I do I leave loading in the BG since I don't have too fast of an Internet connection.



  • VB-17616



  • There's no option to disable directwrite in chromium. Can't report something to be broken if it isn't even there at all. At least in the latest 53.0.2759.0 build from here: https://download-chromium.appspot.com/
    https://i.imgur.com/nIFrhWT.png
    Yes, I use windows 10, but it's not the case, same behavior can be seen on Windows 7.



  • @Sajadi:

    Also, i can't say that the fonts are blurry with direct write enabled..

    They are definitely different at least on my computer. Look for yourself: https://s33.postimg.org/4iq7xgmd9/image.png These were taken on 1.1 version, where fonts are not yet broken.

    The most apparent difference is the UI font. Just look at the word "flags" in the adress bar. The font within the page is also blurrier, although the difference is not as big. For example, look at the button "Reset all to default" and specifically at the letters "R" and "u".

    And this is what happened on 1.2 in addition to occasional lack of anti-aliasing:
    https://s33.postimg.org/pgjm454xr/image.png
    https://s33.postimg.org/osb84kn5r/image.png
    UI font is broken. It's too bold and numbers are escpecially ugly.

    @Sajadi:

    Also, do you use Windows 10? As this is a work in progress it can also break various things.

    I use Windows 8. This also happens on Windows 7.

    @Sajadi:

    Sure there is :)

    vivaldi://flags

    Almost on the top

    I think that screenshot is from chromium.



  • @Sajadi:

    My screenshot is created on an Asus Zenbook with some integrated graphic chip. So, even with a lackluster setting the latest build should offer good font quality.

    Anyway, take a look to your Windows DPI settings.

    According to the internet, Asus Zenbook has 13,3" display with 1920x1080 resolution. Those articles recommending to enable Hi-DPI support and your screenshot which looks very big on my display support that proposition. That's 165.63 DPI. One would have to try really hard to make fonts look bad on such a display. But if you take a regular lower-end laptop with 15,6" display and 1366х768 resolution, that's 100.45 DPI. A totally different world. I tried doing what those articles say and that didn't change anything on my display.

    I don't think it has something to do with graphical drivers. I have Radeon videocard on my laptop and Nvidia videocard on my desktop pc — fonts are identical.

    Well, I'll stay on 1.1 for a while and hope for the best.



  • I don't need any suggestions on how to make fonts look better. And everything is fine with my settings/drivers etc. I need only directwrite disabled without any issues like in chrome/opera/firefox, that's all. For now it's surely Vivaldi bug. This thread is here for devs to see and fix it. For now I'm going back to 1.1 where everything is normal with directwrite disabled.



  • There's no issue in chromium because you CAN'T disable directwrite in chromium. There's no such option in chrome:flags as I have already said.



  • What is your chromium build and where did you get it?
    https://www.chromium.org/getting-involved/download-chromium
    Here's the latest chromium build and there's no such option in chrome:flags. That's why I can't even test it in chromium. So this must be Vivaldi bug because it doesn't occur in opera or chrome (both are chromium-based).



  • Apparently, the Chromium Project team is making some assumptions about hardware compatibility which are false. And good luck getting them to address them.

    The large majority of us (myself, Sajadi, a few million others) are lucky in that the cock-up with Chromium 52 font rendering does not affect us at all. Our fonts remain crisp and clear. I fear that the Chromium Project team's reaction to this may be: "Hey - 80% of browser users are fine with our code - why don't you just go suck eggs?" I hope I'm wrong.





  • I love Vivaldi with all I've got, but if they remove the option to disable DirectWrite and force me to use the Windows default antialiasing settings (ClearType) then sorry I'm going back to Firefox. I simply can't stand Chrome's horrible font rendering on Windows.

    Here's to hoping the dev team can provide an independent implementation for font antialiasing that doesn't depend on Chromium's extremely flawed and distorted one.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.