Random flashes on Vivaldi's screen



  • After installing Vivaldi on OpenSuse Leap 42.1, i am getting a lot of [i]random[/i] flashes on screen (of the browser). I've uploaded a video that records the moment that i get the flashes (around 10 sec of the video). I don't know what is the reason behind this. I am getting that on [b]Vivaldi Stable and Snapshot[/b] (the last one released on March 31) [b]Can someone help me?[/b] :( Link to the video: [url=https://drive.google.com/file/d/0B9O50TW-UmDPdkhDaEZFU0ZxWEE/view]https://drive.google.com/file/d/0B9O50TW-UmDPdkhDaEZFU0ZxWEE/view[/url]



  • Hi, I use Suse Tumbleweed on an older Laptop with Intel graphic chip and had the same problem.
    Check hardware acceleration activate/deactivate with:

    vivaldi://chrome/settings/search#hardware

    Cheers, mib



  • Depends on graphics card chips.
    Disabling GPU-VSync with commandlne parameter –disable-gpu-vsync in desktop shortcut may help.



  • I get this also, for the last week or so, on LinuxMint 17.3 (Cinnamon).

    Will try your work-around Gwen-Dragon. Thanks



  • After a couple of hours with the above I have not noticed any of this behaviour. :)

    Thanks Again



  • Pleaes ol' man tell the ol' dragoness ;) : How did you solve it now?



  • Hi all,
    I also suffered from this flickering and found a proper solution. I do not recommend to use the –disable-gpu-vsync flag, as it causes high CPU load of Vivaldi.
    Here, on my OpenSuse laptop I created a xorg configuration file (/etc/X11/xorg.conf.d/20-intel.conf) with the following content:

    Section "Device"
            Identifier      "Intel Graphics"
            Driver          "intel"
            #Option         "TearFree"      "true"
            Option          "AccelMethod"   "UXA"
    EndSection
    
    ```Restart your x-server session and the flickering is gone. I didn't notice any side effects. B)


  • @mib2berlin:

    Hi, I use Suse Tumbleweed on an older Laptop with Intel graphic chip and had the same problem.
    Check hardware acceleration activate/deactivate with:

    vivaldi://chrome/settings/search#hardware

    Cheers, mib

    After a couple hours, i didn't noticied the bug. So, i think that his answer works like a charm.



  • @Sayonara:

    Hi all,
    I also suffered from this flickering and found a proper solution. I do not recommend to use the –disable-gpu-vsync flag, as it causes high CPU load of Vivaldi.
    Here, on my OpenSuse laptop I created a xorg configuration file (/etc/X11/xorg.conf.d/20-intel.conf) with the following content:

    Section "Device"
            Identifier      "Intel Graphics"
            Driver          "intel"
            #Option         "TearFree"      "true"
            Option          "AccelMethod"   "UXA"
    EndSection
    
    ```Restart your x-server session and the flickering is gone. I didn't notice any side effects. B)
    

    Thanks, it works great now, no flickering :)



  • I used the "Disabling GPU-VSync" suggestion.

    Using a 10 year old Macbook (Interl Graphics) with nothing but Linux Mint. Did not notice any CPU lag but was not looking for it…

    Might also try some of the other suggestions.



  • <small>@guiscaranse:</small><br><blockquote><small>@mib2berlin:</small><br><blockquote>Hi, I use Suse Tumbleweed on an older Laptop with Intel graphic chip and had the same problem.<br />Check hardware acceleration activate/deactivate with:<br /><br />vivaldi://chrome/settings/search#hardware<br /><br />Cheers, mib</blockquote><br />After a couple hours, i didn't noticied the bug. So, i think that his answer works like a charm.</blockquote><br />I tried the above but get nothing but a blank white screen trying to get to chrome://settings. However, I found this in Vivaldi://Flags:<br />Snip>>><br />Hardware-accelerated video decode Mac, Windows, Chrome OS<br />Hardware-accelerated video decode where available. #disable-accelerated-video-decode<br />Sorry, this experiment is not available on your platform. <br /><<<Snip<br />So that option is a no go :(



  • Hi greybeard, on wich platform you are?
    Please add Vivaldi version, GPU and so.

    Cheers, mib



  • Thanks for another (known) hint. Yes, changing the acceleration method for Intel driver in Xorg display server is another method if GPU Vsync does not work.
    But problem solving with flicker and Intel GPUs is not always a single "Take this adivice as working solution".



  • @mib2berlin:

    Hi greybeard, on wich platform you are?
    Please add Vivaldi version, GPU and so.

    Cheers, mib

    Vivaldi 1.3.501.6 (Developer Build) dev (32-bit)
    Revision 913448ac42b4b8bda5aa5fb7e76cbff365453b40
    OS Linux Mint 17.3 (Cinnamon)
    Blink 537.36 (@913448ac42b4b8bda5aa5fb7e76cbff365453b40)
    JavaScript V8 5.1.281.58
    Flash (Disabled)

    Linux 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:37:25 UTC 2015 i686 i686 i686 GNU/Linux

    Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz

    Mobile GM965/GL960 Integrated Graphics Controller

    All running on old Macbook 2,1



  • Hm, I have the same Graphics Controller on Opensuse Tumbleweed 64 and hardware accelerate aktiv.
    Same Vivaldi version too.
    I am sorry, out of ideas.

    Cheers, mib



  • Not an issue… This old box will soon be going out to the recycling bin (even though I call it a "Boat Anchor" I'd not toss it into the river) and a new laptop will replace it (providing I can make a choice !)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.