src="https://update.vivaldi.com/stats/piwik.php?idsite=1&rec=1&bots=1" style="border:0;" alt=""

Problem: Automatic redirect to HTTPS



  • Vivaldi (as well as other Webkit browsers) seems to automatically check if there is a reply on https:// when visiting a http:// url, and then use the https:// one if there is. This behaviour makes [b]no sense at all[/b]: I can't visit certain http:// websites because of this. There is no guarantee that a server serves the same content/website on port 443 as on 80. This makes Vivaldi unusable for some websites. I have to use lynx or crappy Firefox right now, because I can't get it to work in Webkit browsers (tested on Vivaldi, Opera and Chromium). This "feature" should be removed, doesn't even make sense to offer a configuration option.


  • Moderator

    Vivaldi does not redirect automatically to SSL connections if there are http and https domain.
    Please try it!
    Typegwendragon.deand Enter; Vivaldi always will go to```
    http://gwendragon.de



  • True, this site works for me as well. But I still have this problem on an internal site. Let me debug some more to find the difference.


  • Moderator

    I found a bugreport now VB-18012 "Visiting http:// site but Vivaldi is loading https:// + cert warning"
    and can confirm a special issue.



  • Yeah, that's mine - didn't want to publish URL.
    I hope someone tells me what the problem was once this is resolved.. :)


  • Moderator

    Thanks for your report of the issue. :)

    That is really strange. I don't know if this is a bug or a server misconfig.
    Lets wait until one of the Vivaldi devs will have a look at.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.