Instale libffmpeg para Vivaldi em Linux para Debian e derivados


  • Moderator

    Para decodificar transmissão de fluxo contínou de audio e/ou vídeo, Vivaldi utiliza codecs disponíveis no linux. em algumas circunstâncias existe a necessidade da intalação de um pacote extra de bibliotecas para a executar H.264, MP3, MP4 .....

    Continua aqui
    Autoria de Gwen-Dragon



  • brigadissimo.

    deu certo demais, tava sem ver videos de outros sites a nao ser do youtube.


  • Moderator

    de nada! estamos aí para isso.
    o script da gwen precisa ser executado a cada nova versão do Vivaldi.


  • Moderator


  • Moderator

    Atualização do script vivaldi-libffmpeg-install 1.0.5

    • Corrige um erro que ocorria na detecção da versão do Chrome

  • Moderator

    Atualização do script vivaldi-libffmpeg-install 1.0.6

    Novo Recurso: caso o pacote libffmpeg não esteja disponível para o Vivaldi, o script tenta buscar a versão correspondente de um pacote opera-libffmpeg.

    Mudanças no script vivaldi-libffmpeg-install Beta

    • alterações em algumas opções na linha de comando
    • [Recurso] adicionada funcionalidade de trazer a libffmpeg compatível do opera. Se existir, haverá um backup para libffmpeg.

  • Moderator

    Atualização do script vivaldi-libffmpeg-install-1-1-1-en

    Esse script somente é executável para Debian e *buntu. Perdão. Os demais OS, como Arch ou variantes já tem o chromium-codecs-ffmpeg-extra, ou um pacote dedicado exclusivamente ao Vivaldi em algum Repositório mantido pelo responsável

    !!! Por favor, Atenção !!!
    
    • Verifique se você possui qualquer versão antiga da libffmpeg em /opt/vivaldi*/lib ou /opt/vivaldi*/ folders e delete-os.
      Se você utilizou meu antigo script para atualizar a libffmpeg no passado, ele copiaria a libffmpeg.so para as pastas do Vivaldi.
      A existência de tais antigas bibliotecas pode causar crash no Vivaldi com áudio ou vídeo. No antigo modo para corrigir problemas de vídeo codec no Vivaldi, copiando a biblioteca manualmente foi uma boa e útil solução, entretanto agora não é permitido devido a uma falta no Vivaldi: haviam algumas mudanças em versões antigas do Vivaldi, portanto essa forma de cópia não é mais necessária.
    • Então reinstale sua mais recente versão do Vivaldi emitindo os seguintes comandos:
    apt-get install --reinstall vivaldi-stable
    
    apt-get install --reinstall vivaldi-snapshot
    
    • Caso você tenha incluído .vivaldi-libffmpeg-install.sh como um cronjob, por favor, primeiro atualize seu cronjob com a seguinte entrada:
    vivaldi-libffmpeg-install.sh -c
    
    • Inicie a atualização com segue abaixo:
    vivaldi-libffmpeg-install.sh -f
    

    Alterações (desde 1.1.0 BETA)

    Modificações nas opções da linha de comando
    Exclusivamente para Debian e afins (*buntu e Debian), gera um alerta se o SO for diferente
    Removido o download do repo Herecura
    Removido o download da libffmpeg compatível do Opera
    [Nova função] força a instalação sobre uma existente chromium-codecs-ffmpeg-extra
    [Nova função] cronjob para verificação diária de novas atualizações pode ser instalado

    Autora: Gwen-Dragon


  • Moderator

    Atualização do script vivaldi-libffmpeg-install-1-1-3-en

    Veja Antes
    Se você incluiu vivaldi*-libffmpeg-install.sh como um cronjob, por favor, atualize a primeiro a entrada no cron usando o comando abaixo:
    vivaldi*-libffmpeg*-install.sh -c

    Inicie a atualização da libffmpeg com o comando abaixo:
    vivaldi*-libffmpeg-install.sh -f

    Alterações (desde 1.1.2 Beta)

    • Remove automáticamente a antiga /opt/vivaldi*/libffmpeg.so copiada pelo usuário porque a biblioteca não é mais necessária.

  • Moderator

    vivaldi-libffmpeg-install 1.1.4 - New Version

    O lançamento da atualização do vivaldi-libffmpeg-install.sh para a versão 1.1.4 tem algumas mudanças:
    novo pacote de codecs para o Vivaldi 1.8 - estável, novo recurso que permite instalar a libffmpeg.so para o usuário local.

    Meu ( gwen-dragon ) script somente pode ser usado no Debian e Ubuntu. Outras Distros como Arch e outras já dispõem do chromium-codecs-ffmpeg-extra, ou algum pacote de codecs especialmente dedicado ao Vivaldi em algum repositório de um mantedor

    É possível ver todas as opções do comando de linha com:
    vivaldi-libffmpeg-install.sh -?

    Verificar a última versão da libffmpeg:
    vivaldi-libffmpeg-install.sh

    Iniciar a atualização da libffmpeg para um único usuário:
    vivaldi-libffmpeg-install.sh -u -f

    Iniciar atualização da libffmpeg para todo os usuários:
    sudo vivaldi-libffmpeg-install.sh -f

    Caso o script vivaldi-libffmpeg-install.sh tenha sido adicionado como um cronjob, por favor, atualiza a entrada no cronjob usando:
    sudo vivaldi-libffmpeg-install.sh -c

    Alterações

    Pacote para libffmpeg alterada para oxideqt-codecs-extra do Ubuntu
    Removida a detecção da antiga /opt/vivaldi*/libffmpeg.so
    Adicionada opção para instalação na pasta local do usuário
    Adicionada informação no final da instalação onde reside a libffmpeg


  • Moderator

    Atualização do script: vivaldi-libffmpeg-install 1.1.5


  • Moderator

    Atualicação do script: vivaldi-libffmpeg-install 1.1.6


  • Moderator

    Atualização do script: vivaldi-libffmpeg-install 1.2.0

    @gwen-dragon said:

    Meu script vivaldi-libffmpeg-install v1.2.0 foi atualizado em razão das mudanças internas feitas no Vivaldi Stable e Snapshots para o código Chromium 64, que usa uma diferente API para a biblioteca libffmpeg.

    O script não sobrepõe os codecs do Chromium existentes, portanto Chromium funcionará perfeitamente, diferentes libffmpeg não entrarão em conflito. No lugar de alocar a libffmpeg fora da pasta do programa Vivaldi, este script adiciona a nova libffmpeg nas pastas de programa do Vivaldi Stable ou Snapshot.


  • Moderator

    Atualização do script: vivaldi-ffmpeg-install 1.2.1

    @gwen-dragon

    O motivo da atualização é devido a mudança do repo de download para os codecs.


  • Moderator

    Atualização e aprimoramentos do script: vivaldi-ffmpeg-install 1.2.2

    @gwen-dragon said:

    mostra a versão interna e código do pacote instalado
    inclui mais Distros.
    exibe a versão do Vivaldi

    O artigo completo, incluindo Changelog pode ser lido aqui


  • Moderator

    Melhorias e aperfeiçoamentos na nova versão do script vivaldi-ffmpeg-install 1.2.3

    • vasculha todo o sistema em busca das libffmpeg.so instaladas, identificando a versão interna e o código fonte do pacote (para debug no caso de erro, reportar ao Vivaldi)
    • exibe a versão do browser no output (saída)
    • preferencialmente instalar no Debian, Mint e Bunsenlabs <-- atendendo a pedidos :p
    • instalação da biblioteca para usuário local/único
    • compatível com Stable e Snapshots
    • adciona um cron job para *auto update da biblioteca, com periodicidade diária

    Download: https://gwendragon.de/repo/linux/vivaldi/vivaldi-libffmpeg-install.sh


  • Moderator

    Novo script vivaldi-ffmpeg-install 1.2.4 com a implementação de cronjob para single user e melhorias na análise.

    Mudanças recentes

    • Cria cronjob para single user
    • Analisa todos os cronjobs instalados pelo script vivaldi-libffmpeg-install
    • Cria um cronjob para atualização automática da libffmpeg,so para single user

    Download: https://gwendragon.de/repo/linux/vivaldi/vivaldi-libffmpeg-install.sh


  • Moderator

    Atualização vivaldi-debian-install-libffmpeg-1.2.5 com a notificação no Desktop a cada nova versão da libffmpeg.so
    O cronjob também foi aperfeiçoado no intervalo de execução.

    Download: https://gwendragon.de/repo/linux/vivaldi/vivaldi-libffmpeg-install-1-2-5.sh


  • Moderator

    [UPDATE #2] Version 1.2.5-p6 (2018-03-08 19:22 CET)

    @gwen-dragon said:

    um "conserto" na identificação do pacote correto (Ubuntu). O pacote estava "quebrado" antes que fosse agregado a versão libffmpeg.so ..... Leia meu comentário aqui

    Aperfeiçoamentos

    • better cleanup after script end. That fixed the not deleted temp folder.
    • disabled notification for root. That fixed abnormal end of script.

    A solução é baixar a mais nova versão do script . Download: vivaldi-debian-install-libffmpeg-1-2-5-p6


  • Moderator

    Experimental: vivaldi-libffmpeg-install-1-2-6
    A autora do script optou por incluir Experimental, embora as duas novas features foram amplamente testadas, são elas:

    1. exibir a no repositório a versão do Codec - Online
    2. remover todos os Codecs e Cronjobs instalado pelo vivaldi-ffmpeg-install

    Abaixo uma screenshot da feature experimental que mostra online a versão mais recente da libffmpeg.so

    1. no primeiro comando, [$ sudo ./f126p4b.sh -Xrepo]
      sem o switch após -Xrepo, mostra a versão instalada para o Vivaldi Stable
    2. no segundo comando, [$ sudo ./f126p4b.sh -Xrepo -S]
      incluindo o switch "-S" após -Xrepo é para o Snapshot

    Xrepo.png


  • Moderator

    Novo lançamento vivaldi-libffmpeg-install 1.2.7 com mais aprimoramentos:

    1. Cores na saída do script
    2. Verificação rigorosa sobre a incompatibilidade na versão da libffmpeg.so

    Changelog

    • Mensagens de erro e debug coloridas
    • Como proceder quando há incompatibilidade na libffmpeg.so (graças ao Ruarí)
    • Vasculhando todo o sistema a procura de todas libffmpeg.so instaladas e exibindo informações sobre a origem do pacote, versão interna e etc
    • Exibe a versão do Vivaldi e do Chromium interno
    • Notifica sobre updates da libffmpeg.so
    • Better installing on Mint, Debian and Bunsenlabs (a feature request, thanks to Lamarca for report and testing!)
    • Permite instalação para usuário local
    • Recurso de instalar para a Stable e Snapshots
    • Cria uma atualização automático para usuário local
    • Define também para o todo sistema a atualização automática, incluíndo Stable e Snapshots

    Recursos experimentais

    • Verificação Online da versão atual no Repo
    • Exclusão de libffmpeg.so e cron jobs obsoletos

    Download: https://gwendragon.de/repo/linux/vivaldi/vivaldi-libffmpeg-install.sh


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.