BUG: Vivaldi kann Gnome Keyring nicht entsperren



  • Ich habe schon einiges zur Passwort-Problematik in Vivaldi recherchiert und komme jetzt aus folgendem Grund zu dem Schluss, dass das Problem evtl. doch bei Vivaldi liegt. Wenn ich mich an meinem Benutzerkonto anmelde und Vivaldi starte klappt der Zugriff auf die Passwörter nicht. Wenn ich die Passwortseite aus den Einstellungen aufrufe (chrome://settings/passwords) ist diese leer. Starte ich nun Opera und rufe eine Seite auf, für die ich ein Passwort gespeichert habe, erscheint der Dialog zum Entsperren des Gnome Keyring und Opera füllt den Login aus. Ich kann Opera dann auch wieder schließen und anschließend in Vivaldi forfahren, denn jetzt klappt der Zugriff auch hier. Wenn ich jetzt die Passwortseite in den Einstellungen aufrufe, sehe ich meine hinterlegten Passwörter. Vivaldi gibt auf der Konsole einiges an Fehlermeldungen aus: [code] [30130:30162:0525/195334:ERROR:nss_util.cc(839)] After loading Root Certs, loaded==false: NSS error code: -8018 [30130:30160:0525/195334:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30208: Keine Berechtigung [30130:30160:0525/195334:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30237: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30298: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30301: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30302: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30309: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30314: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30320: Keine Berechtigung [30130:30160:0525/195336:ERROR:zygote_host_impl_linux.cc(162)] Failed to adjust OOM score of renderer with pid 30334: Keine Berechtigung ** Message: Remote error from secret service: org.freedesktop.Secret.Error.IsLocked: Cannot get secret of a locked object [30130:30157:0525/195340:ERROR:native_backend_libsecret.cc(644)] Unable to load secret itemCannot get secret of a locked object [/code] An der libsecret kann es meiner Meinung aber nicht liegen, da doch beide Browser auf dieselbe lib zugreifen. Oder? Am Chrome Unterbau kann es wohl auch nicht liegen, da sowohl Opera37 als auch Vivaldi1.1stable Chrome in Version 50.0.2661.94 (Opera) bzw. 50.0.2661.102 (Vivaldi) verwenden. Mein System ist ein LMDE2 (Linux Mint Debian Edition) mit Cinnamon als Desktop.



  • Vivaldi ist aber auf Chromium 51-Basis. Aber trotzdem ist so ein problem nervig genug.
    Aber ich hörte schon von Problemen mit GNOE keyring und auch im Bugtracker sind zwei Meldungen drin.

    Und mit Mint haben so einige ein Problem mit dem Keyring.
    Vielleicht hilft dir das Upgrade der libsrect und libsecret-common:
    http://www.deskmodder.de/phpBB3/viewtopic.php?f=343&t=17287&hilit=keyring&start=30#p275080
    http://www.deskmodder.de/phpBB3/viewtopic.php?f=343&t=17287&hilit=keyring&start=30#p275085
    https://bugs.chromium.org/p/chromium/issues/detail?id=532555#c9



  • Danke Gwen-Dragon.

    Also Vivaldi gibt mir folgende Versionsinfos aus:

    User-Agent	Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36 Vivaldi/1.1.453.59
    

    Die verlinkten Foreneinträge hatte ich schon studiert.
    Ich installiere aber nicht so gerne Updates für libs, die in meinem System-Repo noch nicht bereit stehen.

    Außerdem frage ich mich immer noch, warum Opera es schaft den Gnome-Keyring zu öffnen?
    Der verwendet doch wahrscheinlich auch libsecret in der installierten Version 0.18-1, oder?



  • @Otscho:

    Die verlinkten Foreneinträge hatte ich schon studiert.
    Ich installiere aber nicht so gerne Updates für libs, die in meinem System-Repo noch nicht bereit stehen.

    Das ist aber auch der von Chromium-Entwicklern vorgeschlagene Fix. Und ich habe auch von genügend Mint-Usern gehört, dass ein Upgrade hilft.
    Dann muss du eben warten, bis Mint ein Update bekommt.

    Außerdem frage ich mich immer noch, warum Opera es schaft den Gnome-Keyring zu öffnen?
    Der verwendet doch wahrscheinlich auch libsecret in der installierten Version 0.18-1, oder?

    Was Opera verwendet und geändert hat, weiß ich nicht, da musst bitte du mal auf Opera Linux nach fragen. Vielleicht patchen die den Chromium-Code extra.



  • Ok.
    Es wird aber noch erstaunlicher.
    Wenn ich mit Vivaldi eine Seite öffne und mich dort einlogge fragt Vivaldi, ob ich dieses Passwort speichern will.
    Verneine ich dieses, öffnet Vivaldi den Dialog zum Entsperren des Keyrings :ohmy:
    Danach funktioniert dann auch das Login auf bekannten Seiten.

    Wenn ich aber zuerst eine bekannte Seite ansteuere, für die Vivaldi das Passwort kennt, kommt der Dialog zum Entsperren des Keyrings nicht.



  • Seit dem letzen Update auf Version 1.4.589.29 (Stable channel) (64-Bit) Chrome/53.0.2785.122
    ist das Problem behoben. :)
    Wenn beim Start von Vivaldi eine Seite in einem Tab geöffnet ist, die der Passwort-Manager kennt, fragt er nach dem Passwort zum entsperren.



  • Ah, gut zu hören.
    Freut mich für dich!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.