"Perte" des mots de passe + Utilisation dique importante - crash drag&drop



  • Bonjour/Bonsoir, utilisateur de Vivaldi depuis quelques temps maintenant et venant d'Opera, je rencontre pour la première fois un problème "important" et un autre moindre, j'ai fais 2/3 recherches sur les forum, j'y ai trouvé des sujet similaire en anglais, mais pas de solution fonctionnelles ou d'autre info. Je link les sujets ici même (n'écrivant que très mal l'anglais - je le comprend sans souci, c'est lécriture qui pose un souci - je me permet de faire un sujet à propos de cela en français) : - https://vivaldi.net/en-US/forum/vivaldi-browser/9122-passwords-dissapeared?limitstart=0 - https://vivaldi.net/en-US/forum/vivaldi-browser/11124-passwords - https://vivaldi.net/en-US/forum/security-and-privacy/10629-vivaldi-seems-to-temporarily-forget-saved-passwords J'ai plus ou moins la même situation que dans ces sujets, après un temps relativement réduit (moins de 1/2 mn après le lancement), Vivaldi "perd" l'accès au mots de passe enregistré et dans le même temps l'utilisation disque sur lequel est installé vivaldi grimpe en flêche jusqu'à fermeture (ou kill du processus si vivaldi 1.1.x). J'ai tenté plusieurs des options proposé dans les topic ci-dessus - Désinstallation (en gardant les paramètres utilisateurs pour ne rien perdre) - Réinstallation (avec plusieurs variante, x32/x64, version dev x32/x64, changement du dossier d'installation ...) - Désactivation/réactivation des plugins - Redémarrage de l'ordinateur/sessions. Mais je fini toujours par en revenir au même point (plus de mots de passe après X temps d'utilisation). La seule différence est entre les versions "finale (1.1.x)" et les version "snapshoot" Dans l'utilisation des versions 1.1.x, je dois faire un kill processus car il en reste 2 qui ne sont pas fermés après avoir quitté le navigateur. Par les snapshoot, si je quitte le navigateur il n'y a pas de processus qui restent en arrière plan à utiliser le disque. Je suis avec un win 8.1 à jour et avast en antivirus. Pas de souci détecté sur les disques (checkdsk&cie - le premier "truc" qui me soit venu à l'ésprit et ma plus grande crainte, mais écarté au final). De ce que j'ai lu il ne semblerait pas que cela soit un souci isolé sur un seul utilisateur, d'autre membre de la communauté on eu le problème. Mais pas de solution viable semblerait-il. Si quelqu'un ici connait un moyen de remédier à cela, je suis preneur, car pour le moment j'ai été obligé de passer sur FF (pas de mdp + utilisation disque trop importante, voire bloquant dans certains cas (blocage d'autre application, erreur dans les journaux windows ..)). -------------------------------------- Le 2eme souci rencontré, mais moins bloquant que les mots de passe et l'utilisation disque, c'est au niveau du drag&drop. Il arrive parfois que lors d'un drag&drop d'un élément sur une page (toutes les pages) le navigateur plante, se ferme tout seul et se relance sur les pages qui étaient ouvertes avant le drag&drop. Cela ne le fait pas à chaque fois, c'est peu courant (surtout depuis la dernière maj 1.1 - en 1.0 le problème était plus présent), et cela touche tout les "types" de "drag&drop" (images, liens, texte, déplacement dans un dossier pour save une image ....). Je n'ai pas vu par contre de sujet à propos de ce bug (ou je ne les ai pas trouvés). -------------------------------------- Pour ce qui est du reste du navigateur, je n'ai pas grand à y redire, je retrouve ce que j'avais perdu avec les Maj d"Opera 15+ par rapport à la version 12.x. Utilisation fluide, peu de mémoire utilisé, j'en suis globalement très satisfait (et je l'ai recommandé à certaines de mes connaissances qui regrettaient également les anciennes version d'Opera). Seul le problème décrit dans la première partie de ce post m'a conduit ici et à mettre de coté le navigateur le temps de trouver une solution. Merci à vous pour toute l'aide que vous pourriez m'apporter (et toutes mes excuses si ce sujet n'a pas sa place ici, je début un peu sur les forum de Vivaldi).


  • Moderator

    Salut,
    Pour les problèmes de mots de passe que tu rapportes, il n'y a rien de très probant sur le bug tracker et ce souci ne m'est jamais arrivé.
    Il serait vraiment utile que tu confirmes que le problème est reproductible systématiquement sur la dernière version de développement dispo sur https://vivaldi.net en configuration complètement par défaut donc sans aucune extension ou modification d'options.
    Dans ce cas, il faudrait que tu essayes de voir si il arrive quelques chose au fichier Login Data de ton profil (Aide > À propos… pour le localiser). Fichier absent ? Taille nulle ? Pourrais tu aussi préciser combien de mot de passe (à peu près) tu stockais là dedans ? Juste au cas où : Pourrais tu aussi désactiver ton antivirus ou le régler pour ne pas qu'il s'occupe des affaire de VIvaldi, on ne sait jamais :D
    Confirmes aussi que tu n'utilises pas Vivaldi sur un support amovible monté sur différentes machines. Auquel cas, une modification aussi récente que sécuritaire de Chromium empêche la gestion des mots de passe en "standalone/portable" et seule la synchro des données permettra de résoudre ce "problème".
    Après, si le problème ne survient pas en configuration par défaut, il faudra bien noter toutes les modifications de configuration ou d'extension installées qui pourraient déclencher le phénomène gênant... et rapporter un bug précis à ce sujet en décrivant bien le lien de cause à effet probable.

    À noter que si un fichier contient des données auxquelles tu tiens un peu (signets, mots de passe, notes...), il est prudent de les sauvegarder régulièrement.



  • Bonsoir,

    je vais faire les tests demandé.
    J'ai récup les installateurs pour 1.1.453.59 x32 et x64 ainsi que pour 1.2.485.14 x32 et x64.
    J'ai fait une "save" (cop/col) de tout le dossier vivaldi dans "appdata/local" au cas où.
    Je vais tout virer en gardant la save de coté pour repartir sur une base "saine" (dans ce cas, est-il possible de ré-inclure en "bourrin" les fichiers "login data" et "Bookmarks" pour retrouver les infos sans tout refaire à la main ?).

    Concernant le "Login Data", il n'est pas vide, les données à l'intérieur ont fait quelques voyages à travers divers navigateurs (Opéra 12, 15+, dev puis vivaldi 1.0/1.1) avec les fonctions d'import à chaque fois.
    J'ai bien les MDP, au début, mais après un temps X, c'est Vivaldi qui n'arrive plus à le charger.
    Mais cela revient quand je relance le navigateur (Pendant un temps X, puis rebelote).

    Sur : "vivaldi://settings/passwords" ou "vivaldi://chrome/settings/passwords"
    J'ai bien les mdp, sauf quand Vivaldi commence à partir je ne sais trop où et qu'il utilise le disque d'installation au max, là tout est blanc/vide.

    Concernant mon installation de base, c'est par défaut, je n'ai rien touché dans les paramètres d'installation. Toujours sur le disque système, dossier par défaut (système 64 bits).
    Au niveau du nombre de MDP, j'en ai entre 50/60 depuis que j'ai fait le ménage via le gestionnaire de mdp (sans doute 80/90 avant).
    Certains n'ont pas de login (zone blanche avant la case mdp), d'autres n'avaient pas de mdp associés à un login (zone blanche après le login). J'ai delete tous ces derniers.
    Pour avast, normalement c'est ok, pas d'interférence avec Vivaldi sur mon ordi.

    Je mets ici les 3 plugins utilisés :

    • Wot
    • µblock Origin
    • RSS Feed Reader
      Tous récupéré via l'option "Plus d'extensions" qui renvoi sur le "chrome-store".

    Je vais faire les test, je post les résultats dès que possible.



  • Re,

    je viens de refaire 2/3 tests.
    J'ai viré tout ce qu'il y avait sur l'ordi concernant vivaldi (en ayant une back-up de "appdata/local/vivaldi" mise de coté).
    Désinstallation avec suppression des donnés utilisateurs.
    Installation de la dernière version (1.2.x - il y a eu une maj entre temps, j'ai fait la maj).

    Je suis resté comme cela avec le navigateur ouvert, en changeant de page ci-et là (version "vanilla", pas de mdp/favoris …).
    Pas de soucis au niveau du navigateur (pas de plantage, pas d'écriture disque au max ....).
    J'ai ensuite remis en place via la back-up les mdp+favoris.
    Tout ce déroule bien, pas de "perte" des mdp, pas de souci au niveau de l'utilisation du disque.

    J'ai commencé ensuite à ré-inclure les extensions petit à petit ("µblock origin" dans un premier temps, puis Wot).
    Pas de souci non plus.

    La seule extension qui reste à remettre est "rss feed reader".
    J'attends un peu avant de la ré-installer (fait pendant les tests en même temps que ce post, à voir sur la durée s'il y a un souci avec).

    Contrairement à avant, cette fois ci, la ré-installation à fonctionné correctement (avec suppression des donnés utilisateurs, ce que je n'avais pas fait).
    Il doit/devait y avoir un fichier/dossier quelconque qui posait souci (mais quand à savoir lequel, je n'ai pas d'idée, peut être un souci avec une extension ?).

    Je verrais bien si le problème revient d'ici quelques temps/jours.

    Pour ce qui est des crash avec le drag&drop, je n'ai plus le souci avec la ré-installation complète.



  • Bonsoir à nouveau !

    Je fais remonter le sujet, je n'avais plus de souci depuis un temps (excepté pour le crash du drag&drop) mais cela est revenu il y a peu de temps (aujourd'hui même).

    Tout a fonctionné correctement jusqu'à il y a quelques minutes.
    Même symptôme, "utilisation disque" au max, mots de passes non trouvés …..

    Cependant, j'ai trouvé le moyen de corriger le souci sans avoir à tout réinstaller.
    Il se trouve que dans "AppData\Local\Vivaldi\User Data\Default" il y a un fichier nommé : "Top Sites"
    Normalement, celui-ci ne prend que quelques Mo

    J'avais gardé les fichiers du souci précédent en mai (c'est comme ça que j'ai fait le lien).
    Dans tous les cas où j'ai une utilisation du disque au max, et un souci pour les mdp, ce fichier n'a pas une taille "normale".
    On passe de 3/4 Mo à plus de 100 Mo (respectivement 177 Mo pour mai, et 68 Mo pour ce fin juillet).

    En enlevant le fichier après avoir fermé le navigateur (plus un kill processus) le souci disparaît de lui-même.
    Par contre, je n'ai pas trouvé ce qui provoque le remplissage du fichier "Top Sites"

    Du coup si :

    • Utilisation disque anormale
    • Disparition des mdps après un temps X d'utilisation de vivaldi
      --> Fermer le navigateur, kill du/des processus restants via le gestionnaire des tâches
      --> Vérifier la taille de "AppData\Local\Vivaldi\User Data\Default\Top Sites"
      --> Si sup à quelques Mo, delete le fichier "Top Sites"
      -> Relancer le navigateur
      -> Retour à la normale (en théorie).

    Je garde de coté les fichiers "Top Sites" posant problème si besoin.

    Je précise 2/3 infos

    • Tests sous vivaldi (dev et stable - 1.2x et 1.3.551.x 64bits)
    • Windows 8.1 à jours
    • Pas d’interférence avec l'anti-virus

    Concernant le souci avec le Drag&Drop par contre, j'ai toujours le problème, mais je n'ai pas trouvé de solution.

    Je crash de manière totalement aléatoire si :

    • Déplacement d'un texte sélectionné/surligné (même onglet ou fenêtre)
    • Déplacement d'un lien (même onglet ou fenêtre)
    • Déplacement d'une image (vers un dossiers sur l'ordi, le bureau ...)

    Cela n'arrive pas tout le temps, parfois cela plante le navigateur plusieurs fois par jours, parfois pas du tout de la journée.
    Le navigateur se ferme tout seul, se relance tout seul également sur les onglets ouvert.
    Tant que Vivaldi ne s'est pas relancé, les processus en fond (musiques/vidéos - youtube, twitch ....) continuent de fonctionner.
    Un fois que le Vivaldi se relance, les processus cités se coupent et ne se relance que si je vais manuellement sur les onglets adéquat.

    Je n'ai pas d'autre info à donner sur ce problème ci.



  • Bonjour à toutes et tous,
    Quoi de neuf par rapport à ce problème ?
    Je rencontre les mêmes difficultés depuis 48h :dry: ► Impossible de me connecter à vivaldi mail ou autres sites car les mots de passe disparaissent d'une page à l'autre, et lorsque je vérifie les paramètres, le secteur MdP est totalement vide ! :woohoo:
    Je dois fréquemment fermer Vivaldi, l'ouvrir à nouveau afin de retrouver mes MdP :angry:
    De plus, je constate une surconsommation de mémoire que je n'arrive pas à comprendre ou solutionner :sick:

    Merci pour votre lecture et votre aide éventuelle ! ;)
    Attachments:



  • ►►► Records battus et mots de passe encore disparus !!!
    Attachments:



  • Bonsoir;

    concernant la perte des Mots de passes, j'ai eu le souci encore une fois il y a quelques jours (2 jours de suite malgré la manip indiqué ci-dessus pour "corriger le problème"), depuis je n'ai pas eu à nouveau ce problème.

    "Résolut "comme indiqué ci-dessus en allant supprimer 2 fichiers dans les dossiers du programme.

    Du coup si :

    • Utilisation disque anormale (100% du disque où les fichiers sont stockés - visible avec un "ctrl+maj+echap" sous windows 8.1/10, moniteur de ressources sous win 7)
    • Disparition des mdps après un temps X d'utilisation de vivaldi
      –> Fermer le navigateur, kill du/des processus restants via le gestionnaire des tâches
      --> Vérifier la taille de "AppData\Local\Vivaldi\User Data\Default\Top Sites"
      --> Si sup à quelques Mo, delete le fichier "Top Sites"
      -> Relancer le navigateur
      -> Retour à la normale (en théorie).

    Attention je précise que c'est une solution "maison" de ma part et pas un correctif officiel.
    J'ai trouvé 2/3 topics dans la partie anglophone du forum parlant de souci d’utilisation de disque similaire à cela.

    Pour la mémoire, je constate que Vivaldi en prend peut être un peu plus que ce que j'avais avant avec opera.
    Mais cela dépend pas mal du nombre d'onglet d'ouvert (type d'onglet, youtube à l'air de prendre un peu plus de mémoire qu'une pas lambda en texte) et des plugins installé (adblock/adblock+ prennent pas mal de mémoire).


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.