Blurred & anti-aliased fonts



  • Hello, The latest Vivaldi update ( 1.2.479.8 ) now shows anti-aliased / smoothed / blurred fonts at tab titles, address bar and other places. Even some sites that previously showed perfectly crisp-clear fonts now render blurred fonts in this latest release. I have font anti-alias disabled system-wide. - How can I disable font smoothing in Vivaldi interface? Maybe some vivaldi:flag option? - Maybe could I configure the fonts to be used at the interface? - Could Vivaldi take the system settings again, as in previous releases? I really find aliased fonts much clear and pleasant to read than anti-aliased fonts (blurred). This is why I disable font smoothing everywhere and I setup fonts that render fine without anti-alias / smoothing. Thank you very much.



  • This problem can be solved by disabling the flag DirectWrite Windows (vivaldi://flags#disable-direct-write)

    Once that flag is disabled and Vivaldi is restarted, all texts are crisp clear with pixel-perfect characters again. This is Windows 7 btw.



  • interestingly this only fixes some issues. sometimes if i open a page in a background tab and wait till it's fully rendered before i switch to it, it still is smoothed, even with DW disabled.



  • I have that problem also since a couple of versions [ 32 bits ] and the two flags did not work for me either to fix it; the specific form that problem takes for me is I have an extended screen setup with a second monitor in Windows 10, and when one of the windows of vivaldi are not in focus then the whole view gets blurred. However what is working for me is to go in the nvidia control panel [ ge 740m ] and shift Vivaldi from the nvidia processor to the integrated graphic, then no more problems. I still have to try to test the different antialiasing options and all that but I do not see any drop in performance for my usage case so for now I'm good to go :-)



  • Ahoh, I'm having the same problem of BLUR screens and no one Vivaldi settings have been working to solve this.
    I have GForce 780 and I would like to know WHERE exatcly you set the NVidia settings as you mentioned. I know to open the NVidia panel but I don't know exactly where to add Vivaldi according your mentioned settings.

    Thanks you and regards.



  • Type:
    vivaldi://flags#disable-direct-write

    At Vivaldi's address bar. Or just "vivaldi:flags" (without quotes) and search for the DirectWrite Windows option. Disable it.



  • @davidbens:

    Ahoh, I'm having the same problem of BLUR screens and no one Vivaldi settings have been working to solve this.
    I have GForce 780 and I would like to know WHERE exatcly you set the NVidia settings as you mentioned. I know to open the NVidia panel but I don't know exactly where to add Vivaldi according your mentioned settings.

    Thanks you and regards.

    ¸

    Hello again, sorry for the delayed response;

    in fact it is not working to fix the blurred problems, it's quite random honestly, it comes and goes.. So eventually I'll try to work directly in the settings for the geforce card but for now it's an ongoing bug that I live with as the other features more than make up for that – I make intensive use of the stacked tabs for my work structuring :-)

    Good luck to us :-)



  • as it seem with build 534 the flag vivaldi://flags#disable-direct-write has been removed, so there's no workaround for the blurred text anymore and the bug causing this is still not fixed :(


  • Moderator

    Chromium has removed that setting. Another solution will have to be found.



  • Just logged in to complain about this - the ability to disable directwrite is gone now from Chromium now. I don't know what the devs are thinking, this looks horrible.


  • Moderator


  • Moderator

    Some users really need a better solution.

    And me, too…
    The blurred outwashed fonts are not really good for my old eyes. :(
    I blame the Google and Chromium developers for their bad crappy font rendering engine! :evil:



  • that's one of those moments where you realize what monoculture actually means. so google removes that option and poof, it's gone from vivaldi, it's gone from opera, it's gone from chromium etc.

    and i'm not even sure why they did it. to my understanding we're talking about performance improvements for rendering the tab-bar and the url bar, since the website rendering is still using the os defaults for font smoothing. so was there ever a use case where the web page itself was rendered quickly with the standard way of displaying it but if the text of the tabs could just be rendered 20% faster, it would have been perceived 100% faster?

    to me it sounds like a rather pointless optimization. sadly chrome wont care if they even loose a million users by that as the remaining 499 million probably didn't even recognize the change.

    i still hope that vivaldi can come up with an option to fix this. i have no idea how direct write is supposed to work, but since i know no other application that renders text but does not obey the system font settings, i assume that it can be used in a way that it doesn't automatically smooth the text. and if that's the case, an option should solve all our problems. would be interesting to hear a developers thoughts an this technique.

    edit: https://vivaldi.net/en-US/forum/vivaldi-browser/12782-bring-back-directwrite-flag#68036


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.