Download panel not opening automatically



  • I prefer to tell downloads where to be saved. I have checked the "Open Download Panel Automatically" several times, now, but downloads keep being saved in my "Downloads" folder. What must I do to get Vivaldi to always open the panel, so that I can instruct it where to save individual downloads? Thank you.



  • Hi, this is working for me from the beginning of Vivaldi development.
    Wich Vivaldi version do you use, Windows version and so forth?

    Cheers, mib



  • Thank you for telling me it is working for you. It works occasionally, for me. I'm using Vivaldi for Windows, and it just updated itself again, today, so it should be current. 1.1.453.59
    Also, interesting to me that this response has come in with Vivaldi being all in German, when I have selected English. I'm glad I understand a little bit of German, but I am not fluent in it.


  • Moderator

    You have the current "Stable" version - but not the most recent version.

    If you want to direct where a download is to be saved, you need to have "Always save files to download location" turned off. Whether or not the panel opens is irrelevant. However, if you have it set to always open, and it doesn't, it's likely your profile is corrupted. There's a solution for that, if it's the case.

    But first, make sure the the "Always save…" option is turned off.



  • Right, I do not have a check mark in the "Always Save" box.
    I have only the "Open Download Panel" box checked. I misstated the issue. The little panel comes up, and I click the "Save As" button, which should open the File Explorer dialog box. Occasionally, it does, but most often it does not.

    I tried also removing the path for the default location. That resulted in the download being somehow stored within Vivaldi, but not stored in an identifiable folder. Probably somewhere in the temp folders.

    So, what is wrong, here? Why does the "Save As" button not reliably open the File Explorer dialog box?

    Thank you.


  • Moderator

    Try turning off the Open Download Panel Automatically option. You should still get the "save as" dialogue - perhaps tho one is interfering with the other. Do Not leave your preferred path empty.



  • Thank you, Ayespy. I am doing as you suggest and will let you know the result following my next download effort.



  • Hello, again,

    I have done as Ayespy suggested - removed the checkmark from the "Always open" and restored the path to the default location.

    I just downloaded a video from TED, and although I clicked the "Save As" button, I did not get a File Explorer window. Once again, the download went directly into my Downloads folder.

    I keep my Downloads folder organized, primarily by vendor. So, there is a folder now for Vivaldi, just as there is for Microsoft, Adobe, Mozilla, etc. Within these folders, I have subfolders as needed to keep the different products and installers separate.

    Some things, such as the TED videos, I do not want in my Downloads folder. I want my TED videos in the TED folder inside my Videos folder. It is an annoying extra step to have to fetch the downloaded video from the Downloads folder and move it to the TED folder.

    What must I do with Vivaldi to persuade it to allow me to place my downloaded items where I want them?

    Thanks for your assistance.


  • Moderator

    So the problem you are running into is that Vivaldi fails to override the download instructions coded into the download link in many cases.

    Could you report that to https://vivaldi.com/bugreport.html



  • Thank you, Ayespy, I have now submitted the bug report.
    Have a lovely day.
    TNF


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.