How to force Vivaldi to reload pages on startup



  • Is there an option that force Vivaldi to reload pages from last session on startup? (instead of loading cached pages)



  • +1 !!!

    @ Vivaldi-Team, please have a look at this. I constantly use some 25+ open tabs and every time I restart the browser it only reloads the one single tab which is currently in focus. When I then click another tab I need to wait again until the data is loaded from the net which takes precious seconds. I want that VV reloads every tab at browser startup -> same behaviour as good old Opera12. Feedback appreciated!



  • There are a couple of related flags on Vivaldi://flags.

    Not sure if they are functional. Never tried to play with them.



  • When I want to load many background tabs I simply move cursor to tab bar and scroll over them until all start to load.
    'Switch tabs by scrolling' has to be ON.



  • @greenenemy:

    When I want to load many background tabs I simply move cursor to tab bar and scroll over them until all start to load.
    'Switch tabs by scrolling' has to be ON.

    Some pages will load from cache/some pages from net. I want all tabs to be reloaded from net to their actual state.
    For example, I need to press "reload" on http://www.mmo-champion.com/ (and many other tabs) each time I start browser, but https://vivaldi.net/en-US/ (and some other tabs) reloads itself from net in the same time.



  • Click on first tab(or last), press and hold SHIFT then click on last tab, right click on any tab and chose "reload 'x' tabs".

    I guess I'm the only one who wants tabs to load from cache and truly continue last session where i left off.



  • No, you're not the only one that wants Vivaldi to continue from where it was when it shut down, I like it the way it is now too.

    Vivaldi spends its time constantly writing whatever it's doing to disk non-stop 24/7/365 even after it's downloaded the data to cache and I'd be seriously annoyed if it went through all of that hammering of the drives, then just ignored it on a restart.

    For the moment, the #enable-offline-auto-reload and #enable-offline-auto-reload-visible-only Flags don't have any effect but don't worry, some bright spark will be along to break the restart behavior with no Options and leave the Flags disabled so every page will helpfully reload and lose your place for you after leveling your shiny new SSD.

    Loading the cached pages at start - Pinned and/or Stacked Tabs - would be nice. With a few exceptions I quit using Pinned and Stacked Tabs. Sessions seem to do what I want for now but that may change now that I've mentioned it. :D



  • So no helpful response :(
    I didn't ask opinion whose people who like the current startup behavior. But Vivaldi states it is for experienced people who want customize the browser in their own way. My way is to reload tabs from net on startup.



  • @Argent:

    Is there an option that force Vivaldi to reload pages from last session on startup? (instead of loading cached pages)

    Try adding –disk-cache-size=1 to the Vivaldi startup command line. Not much will be stored in the cache with this method. :-)

    To help with the 'lazy tab' loading I use an extension called Tabs Reloader, and press the button to reload tabs soon after Vivaldi startup. This works with pinned tabs (minimal delay when clicking on tabs), but not with unpinned for some reason.

    Ideally these workarounds should be optional settings in Vivaldi.



  • @Johnny69:

    Ideally these workarounds should be optional settings in Vivaldi.

    Agree.



  • Still no solution?



  • Unfortunately still no solution :-( !!



  • Devs, please consider to add an option to reload pages at startup!



  • Up



  • update instead to latest snapshot and go to settings, uncheck "Lazy loading restored tabs"


  • Moderator

    @iAN CooG:

    update instead to latest snapshot and go to settings, uncheck "Lazy loading restored tabs"

    I think that gets you a cached page, not a new one. User specifically does not want cached pages.



  • It works for my open tabs that loaded cached content previously. I hope the problem is solved finally.
    So move to the next problem - I want classic bookmark menu.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.