Remove Tab Spacing Always [VB-8802]



  • Currently there is the option, "Remove Tab Spacing in Maximized Windows." This is problematic for vertically maximized windows that are not horizontally maximized, or actually any windows that touch the top of the screen. There should really be an option to simply remove the tab spacing everywhere. I don't see any point in ever having the spacing, and it causes a great deal of frustration for vertically maximized windows. Instead of having infinite vertical space to click on the tab, now you have to be very accurate and hit a small target. In Chrome, it's easy to resolve this simply by telling the browser to use the system window border instead of its own (at least in Linux), and then disabling the window border for Chrome. Unfortunately, this does not work in Vivaldi. Check out in my screenshot how Chromium displays the desired behavior, while Vivaldi does not. [img]https://whatimg.com/i/iZ6lxz.png[/img]


  • Moderator

    Opera 12.17 has a setting for Chrome Integration Drag (opera:config#UserPrefs|ChromeIntegrationDragArea), but it still suffers from the same problem.

    The purpose of those few pixels above the tabs in a window that is not maximised is so that users can grab the window to undock it.

    I can see that it would be useful to remove those few pixels from an unmaximised window too, as there are other ways to undock a window with the keyboard.



  • hello, here's what I did for that "problem" of space which is dedicated to the little bar for grouped tabs. so I moved that little bar indicator too:

    ! /* hack space above tabs */
    #browser.win.maximized.tabs-top {
    padding-top: 1px !important;
    }
    .tab-group-indicator {
    margin-top: 4px;
    }
    #tabs-container.top{
    padding-top: 0px !important;
    }

    Note that my tabs are on top just as yours and the option Remove Tab spacing is unchecked



  • Feature already asked, formally.

    (added the relevant bug number to thread's title for your and other users convenience)



  • It would be really nice to be able to force this setting. Not going througt mofying of CSS. Really annoying rocket science for such simple setting.


  • Moderator

    Thea feature is a open request in bugtracker, no progress yet.



  • @Gwen-Dragon I have a related issue and I am not sure if it deserves its own thread. I have "Remove Tab Spacing in Maximized Windows" enabled and sometimes, when the browser launches fully maximized, the spacing remains visible. I have to resize (or undock) the window and then maximize it again to make the spacing go away. Do you know if there is an open request in bugtracker for that?


  • Moderator

    @claraangeles It is a well-known regression that has been around for a month or two. The easiest workaround is to press F11 twice.

    It does not always happen, and so far all efforts to prevent it have failed.



  • @pesala thank you, the F11 trick is faster than what I was doing.


  • Moderator


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.