Browser doesnt launch on Ubuntu 15.10



  • I've installed the browser with terminal and it shows the icon, I click on it and nothing happens. My version is the x64.deb version. Anyone got any idea what's happening?



  • Which Vivaldi version?
    What errors are shown if you start it in the shell?



  • Vivaldi 1.1 64bit DEB I've got this version of Vivaldi.
    The errors are:

    [9102:9102:0511/122246:ERROR:process_singleton_posix.cc(410)] readlink failed: Permission denied
    [9102:9102:0511/122246:ERROR:process_singleton_posix.cc(246)] readlink(/home//.config/vivaldi/SingletonLock) failed: Permission denied
    [9102:9102:0511/122246:ERROR:process_singleton_posix.cc(246)] readlink(/home/
    /.config/vivaldi/SingletonLock) failed: Permission denied
    [9102:9102:0511/122246:ERROR:process_singleton_posix.cc(270)] Failed to create /home//.config/vivaldi/SingletonLock: Permission denied
    [9102:9102:0511/122246:ERROR:process_singleton_posix.cc(410)] readlink failed: Permission denied
    [9102:9102:0511/122246:ERROR:process_singleton_posix.cc(246)] readlink(/home/
    /.config/vivaldi/SingletonLock) failed: Permission denied
    [9102:9102:0511/122246:ERROR:chrome_browser_main.cc(1393)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.
    9102:9142:0511/122246:ERROR:cache_util.cc(134)] Unable to move cache folder /home//.config/vivaldi/ShaderCache/GPUCache to /home/*/.config/vivaldi/ShaderCache/old_GPUCache_000
    [9102:9142:0511/122246:ERROR:cache_creator.cc(129)] Unable to create cache
    [9102:9142:0511/122246:ERROR:shader_disk_cache.cc(589)] Shader Cache Creation failed: -2



  • Strange. I cant get this with Ubuntu 16 LTS.

    Are there any processes running like vivaldi or vivaldi-bin? Look into Ubuntu process manager.





  • No processes are running named Vivaldi, really, like I didn't even click on it.



  • On my Ubuntu 16 all runs fine. 16 is the current version.
    And you cant use Ubuntu 16 and have to stay with Ubuntu 15?



  • Hi, I see a lot permission denied errors.
    Dunno what /home//.config/vivaldi/SingletonLock does but on my system it is a link with 777 rights.
    I would try to delete the complete home/
    /.config/vivaldi/ directory.

    Cheers, mib



  • I'm currently upgrading the system to Ubuntu 16, I'll let you know how that works out.

    EDIT:

    So I've upgraded Ubuntu to 16.04 LTS and then installed Vivaldi with the terminal. At first I encountered a problem with this error:

    dpkg: dependency problems prevent configuration of vivaldi-stable:
    vivaldi-stable depends on libappindicator1; however:
    Package libappindicator1 is not installed.

    dpkg: error processing package vivaldi-stable (–install):
    dependency problems - leaving unconfigured

    But then I've wrote into the terminal

    sudo apt-get -f install

    and then installed again with dpkg command and it finally worked! So currently Vivaldi browser is working on the Ubuntu 16.04 LTS, if anyone is trying this with Ubuntu 15.10, please try upgrading. Thank you for all your help.



  • Fine, that you got the update to Ubuntu 16 and Vivaldi works now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.