Can't make to default browser (standalone install)



  • The "make default browser" button does nothing to me, plus i cant change the default app for the HTTP protocol to vivaldi. Windows 7 standalone install (because i rarely have free space on the system drive)



  • Went through this:
    http://superuser.com/questions/368814/how-do-i-change-my-default-browser-to-an-unlisted-program-in-windows-7

    "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet"
    no other browser was present here, only firefox, opera, chrome (twice), IE and saffari

    "HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations"
    when removing the "user choice" folder, it used the default present here:
    "HKEY_CLASSES_ROOT\http"
    vivaldi was already configured here



  • It should work in Win7. But since it doesn't, just go into control panel/Default Programs and set it there. If you don't know how to do this, I can walk you through it.



  • the problem is, the windows wont bring it up as an option:

    https://gyazo.com/d52df62d175490fd7559b7e824181dc2
    Attachments:



  • Windows has failed to recognize Vivaldi as a browser, but it has not failed to register it as a program. You can go to:
    Control Panel\All Control Panel Items\Default Programs\Set Default Programs
    and select Vivaldi from the list, and then tell Windows to "Set this Program as Default."



  • Unfortunately, its not present there either. i could only set it to files, but not protocols.

    Can it be that the standalone version won't register it as a browser?
    Attachments:



  • It is possible. It's not the case with my copy of Win10 X64, but I have seen it happen before. I don't know why Windows does this, but I have (rarely) seen it happen.

    You may have to do a regular installation, associate all of your file types and protocols, and then your ability to associate a standalone may change.



  • I know Opera doesn't even touch the registry when you do a standalone install; it wouldn't surprise me if V was the same. If Windows doesn't know it is there, you need to make several changes by hand to be able to set it as default. Far simpler to do a regular install and convince it to act like a standalone (have the profile in the same directory) than to set a standalone as default.



  • strange, on my laptop (win10) i can set vivaldi as default when installed standalone



  • This worked for me in Windows 10;

    Right click the Windows Start Button and choose Control Panel from the context menu.
    Top right corner change the "View by:" drop down from Category to Small Icons
    Open "Default Programs" icon
    Select "Set your default programs" link
    Select Vivaldi from the left column
    Then click the "Set this program as default" link at the bottom and click OK.

    You might have to confirm default browser next time you start, but that should do it.



  • @Cybergy said in Can't make to default browser (standalone install):

    This worked for me in Windows 10;

    Right click the Windows Start Button and choose Control Panel from the context menu.
    Top right corner change the "View by:" drop down from Category to Small Icons
    Open "Default Programs" icon
    Select "Set your default programs" link
    Select Vivaldi from the left column
    Then click the "Set this program as default" link at the bottom and click OK.

    You might have to confirm default browser next time you start, but that should do it.

    The problem, as noted by @sgunhouse, is that if standalone Vivaldi doesn't register itself with Windows (and it seems not to), it won't appear in the Control-Panel Default Programs left-hand column. Or at least that's what happens on my Windows 7 system for the various stand-alone Vivaldi versions I have on this system... that is, they aren't in that left-hand list, so they can't be set to default. On the other hand, my 'normal' stable install of Vivaldi does appear in that list and can be set to default.



  • When you install standalone, there is a checkbox in the installer dialog to tell it to register the standalone install.



  • @Ayespy Confirmed on Windows 7 Pro. The old bug is fixed

    @Blackbird You miss your old Vivaldi standalone versions in the Control-Panel Default Programs left-hand column? The reason is the missing entry in "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet". Check in the registry. If you want to differ your various Vivaldi versions go to "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Vivaldi\Capabilities" change "ApplicationName" from "Vivaldi" to your preferred value. Changes in the registry on your own risk.

    Windows 7 Pro (x64)



  • @mottenmouse said in Can't make to default browser (standalone install):

    ...

    @Blackbird You miss your old Vivaldi standalone versions in the Control-Panel Default Programs left-hand column?
    ...

    Actually, no. In fact, I prefer my standalone versions to not have any registry involvement at all. I only install the latest Stable version with registry involvement. It's a habit I formed way back in Olde Opera days to assure system independence and freedom from mutual entanglements for various developmental versions. But thanks for the input anyway; I appreciate it... the technique may come in handy at some future point. In early days, I don't believe the standalone Vivaldi version had the checkbox option in the standalone install panel (which was fine with me), and I never really noticed it being present after it was apparently added at some point.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.