Extensions not Working in Incognito Mode



  • Hello, I'm new to the forum, I just discovered about Vivaldi a couple days ago and I've been giving it a try since then. I quite like the browser overall, I'm just having a few issues, above all: my extensions do not seem to be working when browsing in incognito mode; I activated them for incognito and they were there, but when I started trying to use them they wouldn't respond in any way. I'm on Vivaldi 1.1.453.52, I installed it on three different computers running El Capitan, Mavericks and Yosemite, all of them gave me the same problem. I searched on google and here but it doesn't seem to be the most common issue...



  • I never use incognito mode, but I tried it out now. Seems like extension buttons don't work in incognito mode – for example smart rss. Extensions that do not rely on a button work without a problem -- eg ublock.



  • I use Private Windows daily, and I'm experiencing this problem, too. I'm using Vivaldi 1.1.453.59 on El Capitan. The primary extension I'm having problems with is 1Password. AgileBits just announced official support for Vivaldi (yay!), so I uninstalled and reinstalled the extension, but it still doesn't work. It did work in a previous version of Vivaldi, but I don't know which one. I just know that it did work, but now it doesn't. Probably pre-1.1, I would guess.



  • Just noticed that 1Password works in Private Mode on 1.4.589.11 :woohoo:



  • I noted this in the extensions thread awhile back. Still a thing in 1.4 on my end, at least for uBlock Origin. HTTPS Everywhere is still accessible and operational in private browsing. I was wondering if anyone else, across the board, ran into similar issues.

    Either way, Vivaldi's still only a few years old–counting the snapshots--so I have no doubt it's all a work in progress. Also, I'm speculating that some of the add-ons might be designed specifically for Chrome as opposed to Chromium builds and browsers built upon it. The two extensions I use work, so it doesn't bother me that much, if not at all.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.