Vivaldi flickering when play youtube videos



  • Goodmorning at all! I've a very annoying problem with Vivaldi for Linux (version 1.1.453.52 Stable channel 64 bit). When playing youtube videos, all the open pages, starts to flicker and the navigation is impossible! I use manjaro (arch linux) and Vivaldi installed via aur repository. I'm the only one that have this problem? Is there a solution for this "bug"? Thank you very much in advance!


  • Moderator

    Which graphics GPU or card?



  • Copy/past to lspci:
    VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

    But now I tryed xfce instead of Gnome-shell and all works fine!
    Other browsers (also google-chorme e chromium) however work without problem also in gnome-shell.

    For now I solve my problem with xfce..



  • Same problem here. Vivaldi 1.0.403.24 (Beta 3) beta (64-bit) running on Arch Linux + Gnome 3.20 (Intel GPU).



  • I've tried with cinnamon 3.0.1 (installed via package manager) and the problem is back.
    Cinnamon and Gnome have some common library I know..
    Maybe some of this libraries?



  • Try to diable the desktop composing (how, depends on distros, on the chosen desktop environment, and so on)



  • On Linux Lite I see in Vivaldi YouTube video's without the video, but with a white field in the middle. Never seen it before.
    No problems with other browsers Firefox and Chromium.
    What could it be, I asked myself.

    In the meantime I understand it is something with support by YouTube of the Vivaldi browser in the field of HTML5..? Or can I do something about it?
    Curious is that I can play YouTube video in Mint 17 on an older machine..



  • I installed Disable Youtube™ HTML5 Player 1.1 and there was video.
    And I found on YouTube that this browser plays HTML5 when possible, so I assume if Flash doesn't work Vivaldi plays HTML5. Or is this not so? :)


  • Moderator

    Flicker depends on VSync and/or GPU driver.
    Try to start Vivaldi from shell and some commandline parameter –disable-gpu or --disable-gpu-vsync or --disable-software-rasterize



  • Thank you Gwen-Dragon!
    Opening Vivaldi with –disable-gpu parameter, videos play fine without problem.
    Now, can I resolve the problem with GPU drivers?


  • Moderator

    That depends on the Intel graphic card drivers. You can compile and configurate drivers yourself on Linux with enough knowledge.

    Soryr to say, i only use Ubuntu and Debian.
    Such driver questions about GPU and Hardware acceleration should be asked in a Mint forum
    https://forums.linuxmint.com/viewforum.php?f=59
    Maybe the can help.
    Would you be so kin to ask there and report back?



  • I had the same problem, but not only with youtube, i ubuntu 16.04 with noveau drivers, I fix this issue using official nvidia drivers


  • Moderator

    Yes, thats ok.
    If you can get non-free drivers you should use it.
    The opensource nouveau drivers work mostly, but in past i had to use the NVidia official drivers.



  • Hi all,
    I'm posting just to let you know I have the same problem on my laptop with an Intel chip.
    On my desktop (AMD) no problem at all.
    I managed to fix the flickering by using the –disable-gpu-vsync command line argument.

    Here is the driver information from my laptop:

    cristiano@xmper8q3:~> inxi -G
    Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
               X.Org: 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
               GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 11.2.1
    

    I'm on openSUSE Tumbleweed.

    Cris


  • Moderator

    –disable-gpu-vsync often "repairs" flickering with Intel GPUs not working correctly on VSync.

    Fine, that it helped you.



  • Was having the same problem on linux mint 18 (cinnamon 3.0), graphics chip "Intel Corporation 3rd Gen Core processor Graphics Controller" and it seems –disable-gpu-vsync also fixed the problem for me. I also tried switching to native window in the vivaldi settings and it also seemed to solve the problem, though I didn't try it out long enough to really be sure.



  • This has been annoying me for months. I was scanning the comments on the latest release and somebody suggested that perfomance could be improved by turning off animations. Not only does this seem to have lightened my cpu load, but the flickering appears to be gone. Give it a try if you're still suffering.

    TL;DR
    Settings > Appearance > WINDOW APPEARANCE > Use Animation [TURN OFF]

    edit: there is still occasional flickering but it does seem largely reduced.



  • Thanks to Gwen-Dragon in another thread, I managed to kill off the flickering entirely by editing /etc/X11/xorg.conf.d/20-intel.conf to use DRI3. My config file looks like this:

    @Gwen-Dragon:

    For boards with Intel GPU this helped as Xorg config:

    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod" "sna"
       Option      "DRI" "3"
       Option      "TearFree" "true"
    EndSection
    
    

    I figured it would be useful to post this solution here as well, seeing as this is the first thread I found through a search engine.



  • @DarkWiiPlayer switching to native window removes the flickering. Tested on ElementaryOS Loki.



  • In Ubuntu 16.04 with Intel graphics, enabling DRI3 seems to cause other graphical glitches (corrupted tooltips in Vivaldi, for example). Flickering persists with DRI3 off whether using native window or not on my machine.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.