Keyboard shortcuts for extensions is ineffective

  • I've been using Vivaldi for over a month. I love it! Still, the only flaw that keeps it from being my default browser is that it do not support keyboard shortcuts for extension. I use a web highlighter tool a lot in Chrome, so it's of great importance to me. There's a setting page for shortcuts of extension, exactly the same settings page as in Chrome. But whatever shortcuts I defined in settings, it's ineffective. I'm quite sure the shortcuts I defined are not contradictory with the Vivaldi's default keyboard shortcuts. Is it just me? Or if it's a problem when it's likely to be fixed?

  • I solved it.
    Just switch the keyboard shortcuts valid for "global", the default is "in vivaldi".

  • That's good.

    On this forum you can edit your first post at any time to change the icon.


    • Default = General, Discussion
    • Yellow Exclamation = Bug
    • Question mark = Question, problem
    • Light-bulb = Idea, suggestion, feature request
    • Heart = Positive feedback
    • Merged = Merged topic
    • Red Cross = Crash
    • Green Tick = Resolved

  • Sorry. I intended to use the question mark. But I mistakenly thought the according indicator was after the topic icon.

  • Yes, it's not too obvious. That's why I took the trouble to list them all, hoping that a few others will also read this thread.

  • Vivaldi is the only Chrome based browser I am using, so changing the keyboard shortcut to 'global' validity is not an available option, so I cannot make the extension keyboard shortcut work. Any other workaround?

  • @cheeseburger Hi Cheeseburger, I tried your method on my Vivaldi but the "In vivaldi" button was gray.... Any good solution to for problem?

  • I have the same issue; "In Vivaldi" is greyed out, and I can't use the hotkeys I assign! It's very frustrating...

  • Yes, i dislike it, too.
    That is the unfixed bug VB-14668 "Extensions' keyboard shortcuts don't work"
    No progress as i can see. :(

  • It's interesting that there was a workaround available. But despite having opera stable installed, I'm not able to make it work. Does the second browser need to be chrome or chromium itself?

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.