Black screen at startup Linux Mint 17.3



  • Fresh install of Linux Mint 17.3 in Virtual Box. Vivaldi says it was installed successfully but whenever I go to start it, I just get a black screen. It shows Welcome in the taskbar, but all I get is a black screen. Trying to close Vivaldi by right clicking on the taskbar causes my entire screen to go black and I have to reboot. Any ideas of why it would be doing this? I would like to have it running in Mint, as I really liked Vivaldi on Windows.The bundled Firefox works with no issues.


  • Moderator

    My Lubuntu has sometimes done this. Waiting, or clicking on the black screen after a while, brings it to life. Can't say if your problem is the same, or something different.



  • Thanks, I tried that and still no luck. Other things I have noticed
    The Vivaldi window stays on top, so even if I open another application I have to move the Vivaldi window over to the side - I can move the Vivaldi window, resize it, and so on but all I get is the title bar.
    I have also tried to press F11 to make the window full screen to see if that would refresh the contents, but still nothing but a black screen.



  • Playing around with various settings, I have found that Vivaldi will work properly if I disable 3D acceleration in the video settings in VIrtual Box. It worked okay in Linux Mint 17.2 so I do not know why that would affect it. I am going to ask around on the Virtual Box forums.



  • Dont ask!
    VirtualBox VMs cant do any hardware accelerated OpenGL and therefore VB shwos with Vivaldi and Chromium a black screen.



  • Yes, GD is correct, VB unhelpfully broke 3D acceleration for Linux Guests a couple of updates ago. Yesterday they released 5.0.20, & they acknowledged they’d broken 3D Acceleration in Linux Guests. Sadly however, after upgrading my VM to that new version & re-enabling 3D Acceleration, the chromium-based browsers are still buggered –- hence Vivaldi, Chromium et al chromium-browsers break. As you have already discovered, running your VM without 3D Accel makes V happy again. Aint the bleedin' edge fun?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.