Horrible UI scaling after 1.1.443.3



  • Every version since 1.1.443.3 tries to scale my UI (despite being set to 100%) which leads to too large pages/text with fuzzy text. It is plain unusable (for me). See the two attachments. _ok is the old 1.1.443.3, _bad is the current 1.1.453.45, with identical settings (except for window size, it came up way too large so I had to resize it) Am I overlooking some new variable that needs to be tweaked, or what is going on there? I had hoped it to be a temporary issue, but none of the updates so far brought an improvement :( In case it's related: This is on an 127dpi display. Attachments: [img]https://forum.vivaldi.net/uploads/attachments/26808/vivaldi_ok.jpg[/img],[img]https://forum.vivaldi.net/uploads/attachments/26808/vivaldi_bad.jpg[/img]



  • Hi, after the update to 1.1.453.45 scaling was set to 100% but after set back to my standard setting 90% is all fine again.
    Can you add your system specs, window manager and so forth?
    I am on:

    Opensuse Tumblweed x86_64
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    KDE 5.5.5
    and:

    Opensuse Leap 42.1 x86_64
    Intel i5 3570K
    GTX 760 4 GB /Display card
    GTX 670 2 GB
    Driver 361.28
    KDE 5.5.5

    Without problems with latest snapshot and stable.

    Cheers, mib


  • Vivaldi Team

    @Der_Pit:

    Every version since 1.1.443.3 tries to scale my UI (despite being set to 100%) which leads to too large pages/text with fuzzy text. It is plain unusable (for me). See the two attachments. _ok is the old 1.1.443.3, _bad is the current 1.1.453.45, with identical settings (except for window size, it came up way too large so I had to resize it)

    Am I overlooking some new variable that needs to be tweaked, or what is going on there? I had hoped it to be a temporary issue, but none of the updates so far brought an improvement :(

    In case it's related: This is on an 127dpi display.

    This is not good, and what makes it worse I am not able to reproduce it on my Linux machines here. I will get with the guys and see if there's something going on we can work with. Stay tuned!

    //C



  • Sorry for not replying earlier, my work kept me from doing so :(

    FYI, the problem occur on my laptop (Intel P8700, GeForce 9600M GS, nvidia driver 340.96)
    The system is an openSUSE 13.2 running kde 4.11.20 (main repository)

    I had a try with another system here at work (openSUSE Leap 42.1, i5-6600, GTX 980) which does NOT show the problem. It has a screen resolution of 96dpi.

    The problem on the laptop is absolutely repeatable: Install new version -> scaling occurs. Install old version -> everything fine again, without changes in any configuration setting.

    I'll try to find the time to play with different dpi-settings (override the X server), or another 13.2 system, but cannot promise when….



  • Meanwhile I had the time to play with the X server settings. As I expected, if I override the DPI setting of the monitor and 'fake' a 100dpi display, Vivaldi looks much nicer. However now all the other applications have quite small fonts. Vivaldi seems to have a different opinion on 'correct' sizes of the GUI/fonts than the rest of the desktop….

    Some (easy) way of adjusting the DPI setting for vivaldi would really be nice


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.