[Solved] Can't upgrade to 1.1 rc 3 on Kubuntu 12.04



  • Pepperflash is no longer available for 12.04, but the C library conflict is the biggie. Any workaround? TIA Joe shelelia@halo:~/pq$ sudo apt-get install vivaldi-stable Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: vivaldi-stable : Depends: libstdc++6 (>= 4.8.0) but 4.6.3-1ubuntu5 is to be installed Recommends: pepperflashplugin-nonfree but it is not installable E: Unable to correct problems, you have held broken packages. shelelia@halo:~/pq$ ^C


  • Vivaldi Team

    thanks for reporting, this will be fixed soon. The minimum required libstdc++6 is supposed to be lower.


  • Vivaldi Team

    in the mean time you can force-install

    wget https://repo.vivaldi.com/archive/deb/pool/main/vivaldi-stable_1.1.453.47-1_amd64.deb
    sudo dpkg -i –force-all vivaldi-stable_1.1.453.47-1_amd64.deb



  • @bjorgvin:

    in the mean time you can force-install

    wget https://repo.vivaldi.com/archive/deb/pool/main/vivaldi-stable_1.1.453.47-1_amd64.deb
    sudo dpkg -i –force-all vivaldi-stable_1.1.453.47-1_amd64.deb

    Or, in my case, "…i386.deb." That did it for me. Thanks, bjorgvin!

    Jim


  • Vivaldi Team

    @josephj11:

    Pepperflash is no longer available for 12.04, but the C library conflict is the biggie.

    Any workaround?

    TIA Joe

    shelelia@halo:~/pq$ sudo apt-get install vivaldi-stable
    Reading package lists… Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    vivaldi-stable : Depends: libstdc++6 (>= 4.8.0) but 4.6.3-1ubuntu5 is to be installed
    Recommends: pepperflashplugin-nonfree but it is not installable
    E: Unable to correct problems, you have held broken packages.
    shelelia@halo:~/pq$ ^C

    Asked our dev team about this. No, there's no real workaround for PepperFlash in this context. but we are doing some tests internally. If something comes up, watch this space! :)

    P.S. 16.04 just came out. I know, not a solution, but it is out! :)

    //C



  • @bjorgvin:

    in the mean time you can force-install

    wget https://repo.vivaldi.com/archive/deb/pool/main/vivaldi-stable_1.1.453.47-1_amd64.deb
    sudo dpkg -i –force-all vivaldi-stable_1.1.453.47-1_amd64.deb

    Thanks. That worked, but the wget came back not found for some reason and I downloaded it manually from the browser.



  • @christian:

    Asked our dev team about this. No, there's no real workaround for PepperFlash in this context. but we are doing some tests internally. If something comes up, watch this space! :)

    P.S. 16.04 just came out. I know, not a solution, but it is out! :)

    //C

    Thanks. I'm working on a 15.10 install elsewhere, but it's not ready for prime time.



  • @josephj11:

    @bjorgvin:

    in the mean time you can force-install

    wget https://repo.vivaldi.com/archive/deb/pool/main/vivaldi-stable_1.1.453.47-1_amd64.deb
    sudo dpkg -i –force-all vivaldi-stable_1.1.453.47-1_amd64.deb

    Thanks. That worked, but the wget came back not found for some reason and I downloaded it manually from the browser.

    The new 1.1 release fixed this issue. Vivaldi installs/upgrades from the repo again.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.