Vivaldi and GTK3 font smoothing settings



  • Hello, Iong time Windows user here. I just installed Vivaldi on a Ubuntu Gnome install, and managed to port my profile flawlessly. But there's this little annoyance with the UI and page rendering, in that the app as a whole doesn't respect my GTK3 font smoothing settings, leading to a very disjointed visual experience. I prefer using no hinting, greyscale antialias for the whole UI, while Vivaldi completely ignores those settings (presumably because it doesn't use the GTK toolkit) but I hoped if there is a way to customize the font rendering in Vivaldi. Here's a screenshot so you can see the obvious differences in font rendering between the general UI (Nautilus in this case) and Vivaldi: http://i.imgur.com/MGOxy9f.png



  • I managed to "fix" it by creating a ~/.fonts.conf file to change Fontconfig settings and turn off hinting systemwide. Now it looks much better! Fonts no longer look deformed due to the system autohinter. This is the code if anyone wants it:

    
     <fontconfig><match target="font"><edit name="hinting" mode="assign"><bool>false</bool></edit> 
     <edit name="autohint" mode="assign"><bool>false</bool></edit> 
     <edit name="hintstyle" mode="assign"><const>hintnone</const></edit></match></fontconfig> 
    
    

  • Vivaldi Team

    @rnet:

    I managed to "fix" it by creating a ~/.fonts.conf file to change Fontconfig settings and turn off hinting systemwide. Now it looks much better! Fonts no longer look deformed due to the system autohinter. This is the code if anyone wants it:

    
     <fontconfig><match target="font"><edit name="hinting" mode="assign"><bool>false</bool></edit> 
     <edit name="autohint" mode="assign"><bool>false</bool></edit> 
     <edit name="hintstyle" mode="assign"><const>hintnone</const></edit></match></fontconfig> 
    
    

    I just tried this and you are right, it looks much better on my Ubuntu machine. Fonts are a challenge on Linux though. With all those DE's being in used it's very hard for us to look our best on all of them! :) Thanks!

    //C



  • I've tried this and still Vivaldi UI fonts are not smooth, also –high-dpi-support=1 --force-device-scale-factor=1 doesn't change anything - chrome looks much better
    I'm on Ubuntu 16.04 and latest Vivaldi 1.2, any idea?
    Attachments:



  • @christian:

    I just tried this and you are right, it looks much better on my Ubuntu machine. Fonts are a challenge on Linux though. With all those DE's being in used it's very hard for us to look our best on all of them! :) Thanks!

    //C

    Glad I could be of help :)

    It's a shame how most developers don't pay attention to the typeface despite all the dedication into other fields when it comes to eye candy, such as transparencies and animations. Text is the single most important UI element when using a computer, it would be logical to put the most effort onto developing a sane font rendering system in Linux but sadly it's not the case. In the meantime the only way to do things is by using stopgap measures like these (honestly why is manually editing XML files an acceptable way to configure font rendering in 2016?)

    If Vivaldi could do a Safari on Windows and give an option to enable OSX-like font rendering in non-OSX operating systems (namely Linux and Windows) without needing to delve into external tools like Mactype and Fontconfig it would be awesome and you guys would have my eternal gratitude wink wink ;)

    @slake84:

    I've tried this and still Vivaldi UI fonts are not smooth, also –high-dpi-support=1 --force-device-scale-factor=1 doesn't change anything - chrome looks much better
    I'm on Ubuntu 16.04 and latest Vivaldi 1.2, any idea?

    You might want to try switching the Vivaldi UI to the light theme. Light text on white backgrounds suck in Linux, since it drastically reduces the weight of the font compared to dark text on light backgrounds when having the autohinter disabled.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.