Tab icon close behavior

  • I end up closing my tabs when I'm really trying to select them because of the odd hovering close button that takes the place of the icon just before clicking on it. I looked around in the settings to turn that off without success. Anyone know if there is a wayto change that setting?

  • I had the same issue.

    Under tab settings uncheck "display close tab" and check close tab on double click, although not perfect this took care of the issue for me.

  • Maybe it's possible with custom CSS:

    I like the way it is btw, think you can get used to it 😉

  • This bait-and-switch UI behavior is terrible. Basic controls should not appear out of nowhere.

  • The basic problem is that putting tabs in a horizontal bar at the top is a terrible option for someone who does more than light browsing with just a few tabs. As soon as you have more than 20 tabs or so open in a window (especially on a laptop screen), the individual tabs get really small and you can barely read what's on them.

    Vivaldi tries to attenuate this problem somewhat by hiding the close buttons under the favicons to maximize the amount of readable text in each tab. I can imagine how this does take some getting used to and may be annoying at first, but I don't think it's a bad design decision per se.

    If you insist on keeping your tabs at the top, the solution posted by strichards is a pretty good one (i.e., unchecking "display close tab" and using double-click to close tabs). Closing tabs via double-click is a bit faster than having to hunt for that little x and it has grown so much on me that I really miss it in other apps that have tabs.



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.