No spelling suggestions



  • Hi, i'm use last snapshot version of Vivaldi browser (1.1.453.36 (Developer Build) (64-bit)) under MacOS El Capitan (10.11.3) and have observed that for other language then english i didn't get spelling suggestion in context menu please see the attached images, is there a way to get spelling suggestions for other language in Vivaldi browser? [spoiler][attachment=3334]ScreenShot2016-04-22at10.14.08.png[/attachment][/spoiler] [spoiler][attachment=3335]ScreenShot2016-04-22at10.13.42.png[/attachment][/spoiler] Attachments: [img]https://forum.vivaldi.net/uploads/attachments/79195/ScreenShot2016-04-22at10.14.08.png[/img],[img]https://forum.vivaldi.net/uploads/attachments/79195/ScreenShot2016-04-22at10.13.42.png[/img]



  • You can add more spelling languages.
    1. Open vivaldi://chrome/settings/languages
    2. Add new language
    3. Select [x] Use language for spellcheking
    4. Hit Finished

    Now in a textfield you can open context menu, in Spellcheck select the languages you want to use for spell checking.

    Does this help?



  • Thank you for you're replay, i follow suggested steps, but i can't find where to check "Use language for spellcheking" step 3.
    I get the following window when open vivaldi://chrome/settings/languages

    ! [attachment=3336]ScreenShot2016-04-22at12.37.11.png[/attachment]
    Attachments:



  • Oh, i am on Linux. There these settings exist.
    Strange.

    I thought this exists in Mac, too.


  • Moderator

    It seems that on OS X, all languages added to that list are automatically used for spell checking and there is not additional checkbox for you to check.

    I have two languages in that list and the automatic spellchecker automatically picks the correct language when I start typing in a text field.



  • When from Appel Menu -> System Preferences -> Keyboard -> Spelling, i chose particular language, spelling suggestion for this language appear in context menu when right click under missing spelling word. Interesting how to make browser to pop up spelling suggestion when Automatic by language option is selected in Keyboard System Preferences.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.