Menu closes when reaching separator line in sub menus



  • Hello. I keep running into an UI behavior when using Vivaldi: The main menu (the red V) disappears when I reach a separator line in a sub menu. The reason is that I use one single click to access menus. (Mouse down on the main menu -> move to designated menu -> release mouse button.) To recreate: I press down the left mouse button on the main "V" menu, and while holding down the left mouse button I move down to e.g. "Edit", move out to the sub menu, and when I reach the separator line just above the "Cut" entry, the menu closes. Other windows applications do not do this (try for example MS paint or visual studio). I know that I can avoid this by using 2 mouse clicks to access the menus, but I think this is a clumsy work-around, and I always forget because I usually access menus like this. I'm using Vivaldi 1.0.435.42 (32-bit) in Windows 7, 64-bit.



  • I am also using the latest snapshot build, but I was unable to reproduce this issue, whether using the Horizontal Menu Bar or the Vivaldi button menu.



  • @guineapig:

    Hello.
    I keep running into an UI behavior when using Vivaldi: The main menu (the red V) disappears when I reach a separator line in a sub menu. The reason is that I use one single click to access menus. (Mouse down on the main menu -> move to designated menu -> release mouse button.)

    To recreate: I press down the left mouse button on the main "V" menu, and while holding down the left mouse button I move down to e.g. "Edit", move out to the sub menu, and when I reach the separator line just above the "Cut" entry, the menu closes. Other windows applications do not do this (try for example MS paint or visual studio).

    I'm using Vivaldi 1.0.435.42 (32-bit) in Windows 7, 64-bit.

    I can recreate as you describe (almost click & drag :) ) using Snapshot 1.1.453.6 64bit and the "button menu".
    Note: I actually have to "hover" over the separator for the menu to close, if I bypass it the menu stays open.


  • Moderator

    Confirmed (with dragging over menu) with internal tester version, too.
    That is bug VB-12247 "Vivaldi button menu may lose focus while hovering separator"


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.