Accessing language setting causes the browser to crash



  • Hi It's just like the title says. My hard drive died over last weekend and now I'm rebuilding my system on a new one from scratch. Alas, Vivaldi is not cooperating. The browser is fresh, no plugins installed. It runs polish translation. Unfortunately, I have no access to language settings (right click in this box -> language settings) so if there are any spelling errors, blame the devs :) I've tried to reinstall the browser making sure that all old files were deleted. It didn't help. Could someone offer a suggestion? I was really fond of the possibility to spellcheck several languages at the same time because I'm constantly switching between a few, but now it seems like Vivaldi is highlighting random words. I'm running the latest Vivaldi release (as downloaded from the website minutes ago) on fully updated W7 x64.



  • You cant open vivaldi://chrome/settings/languages ?



  • Well, I can but it instantly craches the browser, and since I have it set to continue previous session after it's restarted, I fall into a loop of instant crashes.

    EDIT:
    The only thing I see in the settings window is "Vivaldi" written in the top left corner, and the browser crashes.



  • I think, your restored Vivaldi profile may be defect.

    Rename you Vivaldi profiel path at %LOCALAPPDATA%\Vivaldi\User Data\Default to Default_BAK
    Start Vivaldi
    Does this work?



  • Unfortunately, it didn't,

    Please have in mind that I did not restore any of my old setting from the old system. It's a clean installation.



  • Sorry for self-bumping this thread but I believe it's justified now.

    I've just installed the latest snapshot release of Vivaldi and I go this:
    https://www.dropbox.com/s/k9uyi61598wexp9/Zrzut ekranu 2016-04-18 19.02.24.png?dl=0

    This looks exactly as right after installing the browser for the first time on my new system, though back then it was "english" twice. When I switched to "all languages", autocorrect became erratic and I was not able to access this nested menu anymore. Attempts to access language settings were resulting with crashes.

    At this moment, I've at least got polish to work properly so I'm apprehensive about touching anything there. Maybe this development will help with designing a solution.

    Vivaldi is still my 2nd choice after Opera 12. All the same, it's a cherished and often indispensable choice.



  • I cant reproduce it, but i used spellcheching for Polski and English for test.
    Changing to all languages or Polski worked and the checker showed me incorrect words.
    No crash.

    I apologize but i cant help you, because i cant use Polski as UI langauge as i am from Germany. ;)

    Please describe the bug clearly and report your issue (in english please) at https://vivaldi.com/bugreport/
    May be a developer can check this.



  • Schade ;)

    Polish is, or at least used to be, an officially unsupported language. It looks like if it was added twice, or some older version of the dictionary wasn't properly replaced. It's also possible that my system setting are affecting it. I'm running an English system and I'm switching from time to time to Polish.

    I'll follow your advice and submit a proper bug report. Let's hope it's fixed rather sooner than later. Spelling-nazis are worse than grammar-nazis.



  • I think your profile is corrupted; you could try this to fix it…. ;)
    Go to %LOCALAPPDATA%\Vivaldi\User Data and rename the "Default" folder to "Backup Default" and then relaunch vivaldi (make sure to close vivaldi before doing this)
    A new "Default" folder will automatically be created, so all you have to do is go back to that directory and delete the "Backup Default" folder..... ;)
    This might fix your problem..... :)

    Hope that helped~ ;)



  • @Maquabra
    Danke, für den Bugreport.

    grammar-adolfs!?
    Not here, never.
    Ehhhmm, such fascists may exist in other forums :)

    Vivaldi is for Friends.



  • @werty

    Thanks for the suggestion but I've already tried that. The browser restarted without any personal settings, just like a clean installation, however this problem happens for me even on a fresh installation, after manually purging every single trace of the browser, so it didn't really change anything.

    I'm quite mad at myself because I remembered to backup all vital Opera's files, but since Vivaldi doesn't have a mail client yet, I forgot about it…



  • There's some progress after the latest update:
    https://dl.dropboxusercontent.com/u/18184780/progress.PNG
    The browser crashes a little further…



  • The journey continues.

    The latest version of Vivaldi allows me to change my basic autocorrection settings from under the rightclick menu, however when I try to access full language option, BSODs happen. I didn't know w browser can cause a BSOD.



  • With the Latest Snapshot 1.1.453.36?
    Oh, what a bad experience. That should not happen.

    I pinged a polish tester to check this with current Snapshot and Windows 7.



  • Hi.
    I work on Windows 7 Professional SP1 64-bit, Polish version. I tested Vivaldi builds 453.36 and 453.43. Standalone installations.
    I can reproduce duplicated entries in language selection context menu. This happens with any language, not only Polish - just install Vivaldi in German or French, right-click in the URL field and you will get duplicated entries for the language of installation.
    I think we should start from fixing this, as this might be a trigger for the crash, which can get fixed together with duplicated entries.

    I cannot reproduce a crash or incorrect words being highlighted.
    Please define precise, concrete steps to reproduce. And please provide a sample text indicating words that are highlighted incorrectly. In the same text are always the same words highlighted, each time? I suggest to use Notes as the easiest to reach test field, but the place probably does not matter.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.