Lastpass extension from Chrome store not able to save new sites



  • Hi, Just wanted to report that the LastPass from the Chrome extension gallery does not allow new sites to be added. You can use the extension to fill forms and select a login username / password but when you try and save a new site then a new tab appears but is always blank. Not sure if a bug in Vivaldi, LastPass or me :) Any advice or work arounds? Thanks



  • Hi Vortal,

    I have the same problem here and haven't found any solution or workaround either

    Have a nice day!



  • Almost the same for me. I've found if you generate the password in Lastpass it stores that as the site and you can then edit it to add the username - better than nothing.



  • Hello,

    The problem is that the extension is written for chrome, so LastPass spawn the page we want, at URLs looking like this:

    chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/tabDialog.html?dialog=site

    And that first part is not excactly correct :-) Changing it to the correct prefix, does not help, as thats a webrequest initiated by the user, and the lastpass addon does not know what to do with that either (the context is missing) :-)

    We will need to wait for an (ugly, i suppose) hack from the Vivaldi developers, OR LastPass to develop a Vivaldi plugin…...
    All "chrome-extension" calls, should be redirected to "vivaldi-extension", or else chrome-extension as a protocol, should be supported in Vivaldi.

    Kind Regards



  • This problem was reported and the Devs know about it.
    The workaround for now is to go to the "My Lastpass Vault" web page.
    There under your login name in the top right select "Toggle Lastpass 3.0" that makes it work as normal.

    It was revealed to me in this thread I started a while back.
    Lastpass borked on all my installs



  • Perfect! Thank you for this tip, perfect workaround!

    Also, I keep being prompted to enter a one time password (two factor security), each time I open Vivaldi.
    Since I started using Vivaldi with LastPass, chrome started prompting like Vivaldi does… So strange!



  • @MrThisgaard:

    Hello,

    The problem is that the extension is written for chrome, so LastPass spawn the page we want, at URLs looking like this:

    chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/tabDialog.html?dialog=site

    And that first part is not excactly correct :-) Changing it to the correct prefix, does not help, as thats a webrequest initiated by the user, and the lastpass addon does not know what to do with that either (the context is missing) :-)

    We will need to wait for an (ugly, i suppose) hack from the Vivaldi developers, OR LastPass to develop a Vivaldi plugin…...
    All "chrome-extension" calls, should be redirected to "vivaldi-extension", or else chrome-extension as a protocol, should be supported in Vivaldi.

    Kind Regards

    If this is the case, I would REALLY like this addressed. I suspect I'm not one of a few, and there is a decent amount of overlap between Power Users that use Vivaldi, and LastPass users. And I do not want to use the workaround of setting it back to v3.0 …

    In the latest build(s) the problems are more substantial. Login via clicking on the toolbar icon, with the small overlay window has an extreme delay. There is no discernable action when you click "Login" and the multifactor authentication comes 12 minutes later.

    The workaround for that is to login at LastPass.com, which should auth your browser app, too.

    This is true of these builds:

    "Vivaldi Classic v1.0":
    Vivaldi: 1.0.435.42
    Rev: 5129d

    AND today's snapshot
    Vivaldi 1.1.453.6



  • In version 1.1.453.45 (Developer Build) (32-bit), this has gotten better. Not only does the re-prompt screen load correctly, I now (correctly) get the following error when two factor authentication is enabled and the damn thing takes too long:
    "ERROR: Sorry, this request is taking longer than normal."

    This is a huge step in the right direction, whether or not it's because of my (very pervasive) post above. Next, making the two factor authentication message seen, and the notification come to my phone. I suspect one fix will fix both.



  • Thanks everyone for taking the time to write about your issues with Lastpass. Sorry about all the troubles and thank you for being patient with us. :(

    FYI we restructured the forum and added a special section for 3rd party and extensions so that this thread was moved there. Also as there is already another thread regarding Lastpass. This one has been closed so that we can monitor the conversation in one place. ;)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.