Consume memory



  • I installed Vivaldi 1.0.435.42 () (64 bits) in my desktop with Windows 8. When I start Vivaldi the consume of memory is low. Later of lot of minutes, the consume of memory is high, similar of Chrome. why is high the consume of memory? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/78379/memory.JPG[/img]



  • Hi, Vivaldi start one thread for each tab, each extension and some more.
    Each thread reserved memory, even it is not used.
    Some other browser are single threaded like Firefox or old Opera, this save memory but if something failed whole browser crash.
    So, regular behavior for modern applications.

    Cheers, mib



  • @mib2berlin said in Consume memory:

    Hi, Vivaldi start one thread for each tab, each extension and some more.
    Each thread reserved memory, even it is not used.
    Some other browser are single threaded like Firefox or old Opera, this save memory but if something failed whole browser crash.
    So, regular behavior for modern applications.

    Cheers, mib

    It couldn't hurt to have an option available though to disable this. Web (formerly Epiphany - which is a Linux browser btw) allows one to disable the one-process-per-tab feature using dconf-editor.



  • @Motionshot I can't use Firefox because of this feature, too slow when loading many tabs or heavily using the browser. Though they are also moving to multi-process system, what I actually prefer.



  • You could start vivaldi with --single-process

    In simpler terms, create a shortcut to your Vivaldi exe and right click, edit. In Linux this option may be called "Make Link". In windows you'll see a path such as "F:\Documents\Vivaldi.exe", you should edit this to append the flag, so it reads something like "F:\Documents\Vivaldi.exe --single-process"

    Source



  • @zaibon said in Consume memory:

    You could start vivaldi with --single-process

    In simpler terms, create a shortcut to your Vivaldi exe and right click, edit. In Linux this option may be called "Make Link". In windows you'll see a path such as "F:\Documents\Vivaldi.exe", you should edit this to append the flag, so it reads something like "F:\Documents\Vivaldi.exe --single-process"

    Source

    I'm using Linux. But thanks, I've added the parameter and will try it out.



  • @Motionshot This works in Linux more or less the same way. Create a link go to the properties of that link and select command


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.