Slowed computer - ubuntu 14.04



  • Hi dear friends. I am a beginner and learn some langages. The global knowlege of computer functioning is for me an entire mystere. As a not specialist many times I have tried to install sofltware manipulating the so called GNOME TERMINAL and partialy failled. A memorable episode was the installation of "Ruby on Rails", houres after houres, tutorial after tutorial, ... chronic failure. In addition the computer slow down day after day. Is it a way to wash it. Is it a way to uninstall the irrelevant pacquets and software? :unsure:



  • Disable zeitgeist, mostly it is the main reason slow response, high CPU/RAM usage in Ubuntu.

    To disable zeitgeist: http://www.staldal.nu/tech/2011/10/27/how-to-disable-activity-logging-in-ubuntu-11-10-oneiric-ozelot/

    If you want to use Linux as development environment, you may start learning enviroments first. Terminal is one of the best thing in Linux I guess. Where did you stuck at the installation of the RoR?



  • Find, I'me grateful for the response @buster.
    first the zeitgeist.
    here is my terminal:
    yvanmoses@yvanmoses-desktop:~$ sudo mv /etc/autostart/zeitgeist-datagub.desktop /etc/xdf/autostart/zeitgeist-datahub.desktop-inactive
    [sudo] password for yvanmoses:
    mv: impossible d'évaluer «/etc/autostart/zeitgeist-datagub.desktop»: Aucun fichier ou dossier de ce type
    yvanmoses@yvanmoses-desktop:~$ ^C
    yvanmoses@yvanmoses-desktop:~$
    It says that there is no such directory
    Is it trustworthy?



  • but I find this:
    yvanmoses@yvanmoses-desktop:~$ man -k zeitgeist
    zeitgeist-daemon (1) - D-Bus interface providing a log of activities
    zeitgeist-datahub (1) - passive loggers for Zeitgeist
    yvanmoses@yvanmoses-desktop:~$



  • Can you try to remove it? I am using 14.10 and removed it directly.
    $ sudo apt-get remove zeitgeist
    But be careful, since it's a unity service, it can remove unity too. So, if you see "unity to be removed", cancel action.

    My suggestion is changing your Desktop Environment (If Unity isn't vital). You can do more with changing Desktop from Unity to Mate. It will increase performance dramatically. Unity requires hardware-acceleration for animation and other things which mostly makes PC unstable even with high-profile GPU. Vendor drivers isn't good. So, you can use Mate for fast desktop, you can easily revert back to Unity whenever you want.
    http://www.omgubuntu.co.uk/2014/08/install-mate-desktop-ubuntu-14-04-lts

    Since you are trying to learn languages, Desktop environment doesn't affect your usage very much.



  • yvanmoses@yvanmoses-desktop:~$ sudo mv /etc/xdg/autostart/zeitgeist-datagub.desktop /etc/xdf/autostart/zeitgeist-datahub.desktop-inactive

    Maybe you are missing something… You can copy from browser (Ctrl+C) and paste console command to terminal (Shift+Insert). :P



  • to @buster
    I'll and report you th result!



  • @white
    Thank's for th "shift + insert" patent. in the past I paste with the right click + paste



  • I tryed to install RVM
    and the result is an error:
    yvanmoses@yvanmoses-desktop:~$ \curl sSL https://get.rvm.io | bash curl: (6) Couldn't resolve host 'sSL' % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 –:--:-- --:--:-- --:--:-- 0curl: (77) error setting certificate verify locations: CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none



  • It should be $ curl -sSL https://get.rvm.io | bash



  • to @buster
    I tryed with your modificatiion.

    yvanmoses@yvanmoses-desktop:~$ curl -sSL get.rvm.io | bash 
    curl: (77) error setting certificate verify locations:
      CAfile: /etc/pki/tls/certs/ca-bundle.crt
      CApath: none
    yvanmoses@yvanmoses-desktop:~$ 
    
    ```The result sames similar


  • Did you run $ gpg –keyserver hkp://keys.gnupg.net --recv-keys D39DC0E3 before start installing?



  • Yes



  • I guess it won't be a problem installing without certification check.

    Try this:
    $ curl -k -sSL get.rvm.io | bash



  • OK.

    yvanmoses@yvanmoses-desktop:~$ $ curl -k -sSL get.rvm.io | bash 
    $ : commande introuvable # translate: command not found
    yvanmoses@yvanmoses-desktop:~$ 
    
    

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.