Adobe Flash Player plugin



  • How i can use Adobe Flash Player NPAPI plugin instead PPAPI ? Its turned on both by default in plugins [attachment:1]Adobe Flash Player plugin.jpg[/attachment] and seems like Vivaldi used PPAPI plugin. When i disable PPAPI, flash content not working at all, whats wrong? NPAPI works fine in my firefox.



  • Dont use NPAPI Flash, it is less safe than PPAPI.



  • @alexer005:

    How i can use Adobe Flash Player NPAPI plugin instead PPAPI ? Its turned on both by default in plugins (snip)
    and seems like Vivaldi used PPAPI plugin.
    When i disable PPAPI, flash content not working at all, whats wrong? NPAPI works fine in my firefox.

    As Gwen-Dragon said, you should DISable NPAPI and ENable PPAPI as that is the one Vivaldi requires.



  • Flash player works in Opera 12.18, the same URL does not work in Vivaldi. What's to do?



  • Opera 12 uses very old Flash player with Netscape plugins.
    Thats not recommended in Vivaldi. Why? Security, stability.

    You need Flash Player 21 PPAPI.

    Open Windows Systemsettings
    Goto Installed programs
    Uninstall old "Adobe Flash Player PPAPI" versions!

    Open https://get.adobe.com/en/flashplayer/otherversions/
    Select your Windows version
    Select "Flash Player 21 for Opera and Chromium PPAPI"
    Download installer
    Start Installer



  • Thanks Gwen-Dragon. I have the mentionned new flash player, but no working. In Edge the URL is working also.
    Starting URL in Vivaldi I can see shortly the first frame/picture from the video, and after black.



  • @ssemoa:

    Thanks Gwen-Dragon. I have the mentionned new flash player, but no working. In Edge the URL is working also.
    Starting URL in Vivaldi I can see shortly the first frame/picture from the video, and after black.

    First double check the installed plug-in
    Tools/Plugins and click on the details link at upper right.
    Please confirm that it says
    "Location: C:\WINDOWS\system32\Macromed\Flash\pepflashplayer64_21_0_0_213.dll
    Type: PPAPI (out-of-process)"

    And NOT
    "Location: C:\WINDOWS\system32\Macromed\Flash\NPSWF64_21_0_0_213.dll
    Type: NPAPI"

    If you have both, ENABLE the PPAPI and DISABLE the NPAPI (just to be sure).
    If that doesn't solve the problem, could you post the URLs of the videos??



  • Installation is in "Location: C:\WINDOWS\system32\Macromed\Flash\pepflashplayer64_21_0_0_213.dll
    Type: PPAPI (out-of-process)". and the URL is http://www.blick.ch/news/hillary-clinton-kaempft-gegen-metro-station-eine-schranke-gegen-die-bodenstaendigkeit-id4896130.html



  • OK, the Blick video is working for me. (5 ticket swipes :) )
    Have you perhaps installed some extensions which might be blocking it?

    Another thing that has helped "some people" - but not all is the "Use Hardware acceleration" flag.
    chrome://settings/search#hardware

    You could try changing that setting.
    Note: Be sure to enter chrome and not Vivaldi as it isn't available via the Vivaldi settings (yet) although Vivaldi will rewrite the address after loading.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.