Display problem with upgrade to 1.0 Stable



  • Since upgrading to 1.0 Stable - and 1.0.435.42 - the page display flickers or blinks periodically - only the Vivladi window. There does not seem to be any obvious trigger but it tends to happen when first opening a page. I did not have the problem with previous versions. The machine is a Gigabyte GB-BXBT 1900 and the lspci output for the video is: 00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e) (prog-if 00 [VGA controller]) DeviceName: Onboard IGD Subsystem: Gigabyte Technology Co., Ltd Device 1000 Flags: bus master, fast devsel, latency 0, IRQ 90 Memory at d0000000 (32-bit, non-prefetchable) [size=4M] Memory at c0000000 (32-bit, prefetchable) [size=256M] I/O ports at f080 [size=8] Expansion ROM at <unassigned>[disabled] Capabilities: [d0] Power Management version 2 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Capabilities: [b0] Vendor Specific Information: Len=07 Kernel driver in use: i915</unassigned>





  • I have the same problem. –disable-gpu-vsync dosen't help.

    Kernel Linux 3.19.0-26-generic (x86_64)
    Distribution Ubuntu 15.04
    Desktop Environment GNOME (gnome)

    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
    Subsystem: Lenovo Device [17aa:220c]



  • Thanks to Gwen-Dragon, the –disable-gpu-vsync seems to work so far.

    Further information, if it helps:
    7.7 GiB memory
    Intel Celeron J1900 1.99GHz x 4 CPU
    Intel Bay Trail Graphics
    Linux Generic 4.2.0.35.38



  • I use archlinux + Plasma 5.x and the solution I found was editing the file 20-intel.conf to change the 2D acceleration SNA to UXA by the following line:

    Option "AccelMethod" "uxa"



  • Same issue on Deepin(debian based, x64). UI is flickering, yet another HUGE bug. Ugh!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.