Mint 17 KDE Screen flickering issues with discrete GPU



  • Vivaldi seems a wonderful, feature rich browser - just what the doctor ordered! However, - a curious issue with 1.0 on Linux mint 17-KDE, running nvidia-prime - everything works fine when using the nvidia GPU, but as soon as I switch to the intel GPU, I get a very annoying flickering. I have narrowed the problem down to the two GPUs, but I'm not altogether sure how to fix it. Surely a browser should run well on a fairly up to date discrete GPU? Curious!



  • May be a problem with OpenGL and hardware acceleration or VSnyc.
    Intel GPU is slower and may be cause flickering while redraw of OpenGL or video buffer.



  • I wondered that too - In fact it's a very v-sync like flicker. The curious thing is that the same system runs chromium perfectly. Experimentation in vivaldi://flags/ doesn't seem to have much of an effect.



  • Solved it! May be useful should anyone else stumble across this thread.
    No amount of tinkering with GPU-related settings in vivaldi://flags has helped. However thinking of vsync (thanks Gwen-Dragon!) I ran it from the command line with the flag:-
    –disable-gpu-vsync
    Obviously I then changed the launcher…
    Sorted. It may be worth pointing out that in KDE the "relaunch" button in vivaldi://flags was proving troublesome - not cleaning up processes after itself, so this slowed the troubleshooting a bit (it proved more reliable to shut then restart the program manually).

    Hope this is of use to someone, and thanks Gwen-Dragon!



  • Ah VSync. Good to know.

    That is indeed a fine and useful tip for us.
    Thanks a lot. :)



  • Experiencing the same problem. Disabling GPU vsync fixes the flickering, but it also puts way more strain on my CPU whenever I watch a video of any kind. I just updated from Linux Mint 17.3 to 18 a few days ago, and that's when this problem started (I was using vivaldi on the old installation as well). Any idea what could be causing this? maybe mint 18 has a different version of some graphics driver?

    EDIT: I already mentioned this in another thread about this problem, but now I tried it for a few minutes and switching to native window really does fix the problem. In conclusion, it is probably a combination of some driver and the way the vivaldi window works.



  • For boards with Intel GPU this helped as Xorg config:

    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod" "sna"
       Option      "DRI" "3"
       Option      "TearFree" "true"
    EndSection
    
    

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.