Dramatic performance breakdown since update to 1.0



  • Hi Today I got the update to version 1.0 (1.0.435.38 to be more precise) on my Kubuntu 14.04 / 64bit system. Since the update I see a dramatic breakdown of performance in Vivaldi, especially on YouTube. When I start a video (using HTML5, not flash), performance is terrible meaning the video being choppy and scrolling trough the website (e.g. comments) is choppy too. Before todays update (on the preview versions) there were absolutely no performance problems at all. I could have 20 tabs with videos open without having any trouble. Now even one tab doesn't work. Anyone else with this issue?



  • Hi, Vivaldi team updated the version 1 to 1.0.435.40 after some some hours, update over Yast on opensuse does not work.
    I downloaded new build and updated manually.
    Dunno if they do some last fixes but have no slowdowns at all with .40 on my system.

    Opensuse Tumblweed x86_64
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    Vivaldi 1.0

    Cheers, mib



  • Try turn off smooth scrolling. In my situation it's helped. Ofc I hope it's temporary advice ;)


  • Moderator

    You have install the appropirate codecs for Vivaldi and Chromium?

    sudo apt-get update && sudo apt-get install chromium-codecs-ffmpeg-extra

    Or you try my script from https://labs.gwendragon.de/blog/Web/Browser/Vivaldi/vivaldi-debian-install-libffmpeg to update the corect libffmpeg.so

    And please read https://gist.github.com/ruario/bec42d156d30affef655



  • @ all

    Oddly enough, the performance problems seem to have improved some hours & reboots later. So this is not much of any issue anymore now.

    On the other hand I had two system crashes/lockups yesterday while using Vivaldi on a system that normally only sees one lockup a year.

    @ mib2berlin

    Updating via the updater in Kubuntu also didn't work. It uninstalled the preview but didn't install the stable version afterwards. Had to do it manually.

    @ r4f4l

    I can't finde an option called "smooth scrolling", Where is it located?

    @ Gwen-Dragon

    Yes, the codecs are already installed.



  • Hi, I think it meant checkbox in Webpage.
    For me the setting change nothing.

    Cheers, mib
    Attachments:



  • @ Topic

    While the performance problems are still gone (well not gone but much better than when I posted first) I'm still experienceing complete system lockups when using Vivaldi.

    @ mib2berlin

    I checked the box. Didn't help.



  • @b00nish:

    I can't finde an option called "smooth scrolling", Where is it located?

    link:
    vivaldi://settings/webpages/

    or:
    Preferences (alt-P)
    Webpages

    or:
    Preferences
    search: webpages

    (searching for "scroll " or "smooth" does NOT work - feels like a bug to me) (?)



  • I just wanted to note that I still experience an average of one system crash per day while watching HTML5 Video in Vivaldi on YouTube. This means that Vivaldi crashed my computer more often in the last two weeks that it has crashed during the last two years. The pain started with the "final" version, the preview versions were fine.

    EDIT: I also seem to experience the crashes when not watching HTML5-Video. Also they have become more often. About 2-3 times a day now. Situation becomes unbearable.



  • Just in case someone else experiences multiple system-freezes per day when using Vivaldi:

    The problem seems to be related to the "nouveau" driver for nVidia garphics cards on Linux. Similar problems have been reported in the past from users of "Chromium" (same engine as in Vivaldi) .

    Obviously the "Chromium" Engine and the "Nouveau" driver don't work well together under some circumstances. And something in Vivaldi final seems to trigger it that hasn't triggered it in the preview versions…

    I'll test in the future if I have more luck with updates Nouveau-Versions. For now, usage of Vivaldi unfortunately has become quite impossible, because I can't have a freeze that requires a reboot every hour.



  • To find the Smooth Scrolling option go to Settings>Webpages & the Smooth Scrolling check box should be first item.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.