Cannot install on windows 10.



  • When I try to install, pop up says "This APP can't run on your PC". anyone has same problem?



  • Only a guess, but it may be that you downloaded the 64 bit version of Vivaldi although you are running 32 bit windows?
    Go to
    https://vivaldi.com/download/

    and pick the "correct" version under "other Operating Systems".



  • Thank you for your reply. My OS is 64x. I have tried installing 32x aswell. getting same message.
    I have attached the error messages i get
    Attachments:
    ,



  • Ahh. Windows Smartscreen

    This restriction has been put in place by the "system administrator".
    If that is you, then log in to the admin user and change the setting (or install Vivaldi from there).
    If you are not the admin - ask them to allow/authorise Vivaldi :)



  • You are awesome. I am managed to install in it on my administration account. But I don't know how to enable this to my other account. Can you please help me on this?



  • As a one-off, when installing a program as admin you should select "install for all users".

    For a more permanent change:
    It is possible for administrator to authorise users to install program from their own account (after requiring them to enter the admin password).
    But Windows 10 is not user friendly when it comes to changing these settings for an existing account (translation: I'm not sure how you do it).

    You could try via Settings/System/Apps & features
    Then scroll to bottom and click on "Program and Features"

    Then in the new window "Control Panel Home" and then investigate under "security and Maintenance" for Smartscreen settings.
    But if you user account was configured under Family & Friends this might not work.

    Basically, for this permanent change to user account settings, you need more expert Windows 10 support than I can give because of the variations possible.
    Maybe try the forums at http://www.tenforums.com/



  • I am having the same problem, tried 32bit and 64bit, my account is an administrator.
    Would love to check out this new promising browser, but can't get it to work. Please help, thanks.

    EDIT: redownloading helped, worked right away. Your downloads seem to not always run smooth and then only half of the download is on the hard drive even though the browser says it's finished.



  • im also facing the same problem. not able to install even though i used x64 version and and ran as administrator.
    Edit : i have 2 win10 pcs (x64), facing same problem in both the pcs
    Attachments:


  • Moderator

    Remove all traces of the old files (or move/re-name them), re-start the machine, and then install with elevated privileges.



  • didn't work either. somuch to do for installation of a browser… this is not Tesla car.


  • Moderator

    @skarlapudi:

    didn't work either. somuch to do for installation of a browser… this is not Tesla car.

    Your problem is not typical. Before today, I had seen it once in fifteen months. The procedure I mentioned fixed it.

    If it's not working for you, I have to suspect something corrupt in your registry, and/or a problem with 3rd party security software. Once in a blue moon Windows firewall will block a perfectly valid installer, but I have not heard of it doing it to Vivaldi.

    Maybe the developers can duplicate your problem if you give them enough info about your setup - but probably not - and if they can't replicate it, I don't know offhand how they would fix it.



  • i think i was rude in undermining the efforts of your team. who knows Vivaldi might become big in coming days… all the best guys :)



  • I have managed it. Thank you so much for your help :)


  • Moderator

    @myurathan:

    I have managed it. Thank you so much for your help :)

    Could you tell us what resolved it for you, in case another user runs into it?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.