[Solved] Fedora 23 + Gnome + Hexchat, window opening issue



  • Hi, I just started using Vivaldi today and I like - A LOT - but one annoying thing. I set the browser to be system default, but when I click a link in my IRC client the tab opens (somewhere) but in some background state so you can't see it (but you can hear it if it's a YouTube video or something, and you can see the process in the system monitor). This isn't a system wide issue - LibreOffice, for example, opens links just fine, as does the system default PDF reader. It's just Hexchat that has this issue it seems (and yes, I did restart it and Gnome too). It doesn't have this problem with Google Chrome or Firefox - when they are the system default browser they behave as expected - link clicks work fine, open a new tab at the end of the existing tabs. It's just Vivaldi that seems to cause this weird "background tab" kind of behaviour, where you have to hunt down the process and kill it to clear the invisible tab. System info: [code]Fedora 23 kernel 4.4.6-300.fc23.x86_64 hexchat 2.10.2-4.fc23.x86_64 gnome-shell 3.18.4-1.fc23.x86_64[/code] Vivaldi info: [code]Vivaldi 1.0.435.40 () (64-bit) Revision 575538bc320e213510be1e66f3521382e615129d OS Linux Blink 537.36 (@0) JavaScript V8 4.9.385.33 Flash 21.0.0.197 User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36 Vivaldi/1.0.435.40 Command Line /usr/bin/vivaldi-stable --ppapi-flash-path=/opt/google/chrome/PepperFlash/libpepflashplayer.so --ppapi-flash-version=21.0.0.197 --always-authorize-plugins --disable-translate --window-depth=24 --flag-switches-begin --flag-switches-end Executable Path /opt/vivaldi/vivaldi Profile Path /home/greg/.config/vivaldi/Default Variations 16e0dd70-3f4a17df cf5ed6e1-3f4a17df 775ebbd7-3d47f4f4 4ea303a6-3f4a17df dbffab5d-f51b51 c8b9b12d-d93a0620 867c4c68-3f4a17df[/code] Hope that's useful! Let me know if you need more information, logs, etc.



  • For some reason this appears to have cured itself. I'm not sure what I did, it might be because I juggled tabs around in Vivaldi, it might be something else, but the problem has gone away. Weird! Information is here if anyone cares to try and repeat it. I will re-post if I can figure out a way to reliably repeat the behaviour. But for now, nothing to see here! :-)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.