How to remove (non existent) results from address autocomplete



  • How to remove results from address autocomplete? This annoys me a lot. Because when I mistype an address, (and alphabetically) it appears before the one I really want, it keeps suggesting it. And because the mistyped site, does not exist, it does not show up in the history, so there is no way to remove it. [b]Example[/b]: I want to visit a large Dutch forum. I type in, forum.foknl (forget the decimal point). Site not found. ok.. correct it, type in forum.fok.nl, works. great. Now.. every single time I type in forum.fo and want to press enter, it defaults to the non-existing .foknl from the first time. To I have to type-out the whole url, every, single, time. I have tried clearing "private data", typing the correct url 20 times, closing browser, clearing cache, removing history. Nothing works, it just keeps suggesting the non-existing page before the correct one and there seems no way to remove the thing. Anyone knows a fix? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/76070/autocomplete.jpg[/img]



  • Did you already try clicking the little x to the right of the URL?



  • There is no little X to the right of the url.. that is why I posted the screenshot.

    There ìs a X to the right of the correct url from the history (forum.fok.nl/..), but not to the false suggestion of the previously mistyped forum.fokyo in the screen, (I typed forum.f for this screenshot, the rest is the autocomplete causing my issue). There seems no way to remove the forum.fokyo (and forum.foknl after I typed that on purpose to test this issue).

    I would expect something like a right-click on the autocomplete suggestion and "remove from list" or something like that. But there isn't. Nor does delete of shift delete work on it, or even clearing my entire history (it removes all visited (real) pages, but leaves the non-existing typo ones..)

    Try it yourself.. type vivaldinet (so forget the decimalpoint) in your browser, press enter. After that type vivaldi.net and try to find a way to have it show that url the next time you want to visit vivaldi.. it will keep displaying vivaldinet as the top/main autocomplete result, every-time you type vivaldi.. making you press the down arrow at-least 2 times for the vivaldi.net result.



  • You don't mention your version of Vivaldi.
    There have been quite a few changes to bookmark and url handling since Beta 3.
    So I suggest you try the latest snapshot from https://vivaldi.net/en-US/

    To check, I tried your "test" in Vivaldi Snapshot 1.0.435.26 (on Win 10) and cannot reproduce the problem.
    For me the "invalid" url vivaldinet is NOT offered by auto-complete/suggestions.



  • @TbGbe:

    You don't mention your version of Vivaldi.
    There have been quite a few changes to bookmark and url handling since Beta 3.

    That fixed it ;)
    I was running 1.0.403.24 (Beta 3) and now run 1.0.435.26 (Developer Build) .
    The problem is still here (I can replicate it with any url I try and leave out the decimal point). However, there is now the option to remove them with a little X. B)



  • Not the solution I expected - but a solution is a solution :)



  • @CrashO:

    There is no little X to the right of the url.. that is why I posted the screenshot..

    The x only shows up on the highlighted URL.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.