Smooth scrolling is not smooth



  • Using Vivaldi 1.0.403.24 (Beta 3) under Windows 7, page scrolling set to smooth is anything but smooth. Page content jumps in approximately 28mm segments on a 24" monitor with the mouse wheel. This is not the case in Firefox on the same computer. Is this a known issue? Thanks.



  • First of all, is smooth scrolling checked? (Tools->Settings->Webpages->Check "Smooth Scrolling")
    If it is, then probably it is some issue with your computer or internet connection (slow internet connection can result in jumpy scrolling)
    I don't think it's an issue with vivaldi, because mine is scrolling very smoothly right now…. B)
    If it persists, try cleaning up your hard drive a bit with a cleaner (CCleaner or Wise Disk Cleaner recommended)
    If nothing works, you could try reinstalling, but there's no guarantee that it will fix the problem..... :dry:
    I hope that helped; if you have any questions, feel free to ask!! :)



  • @werty8763:

    First of all, is smooth scrolling checked? (Tools->Settings->Webpages->Check "Smooth Scrolling")
    If it is, then probably it is some issue with your computer or internet connection (slow internet connection can result in jumpy scrolling)

    Yes, smooth scrolling is checked as my opening post suggested. My internet connection is high-speed fibre and working perfectly. I cannot see how that would have any influence on a fully loaded web page.

    I don't think it's an issue with vivaldi, because mine is scrolling very smoothly right now…. B)

    I had upgraded each beta release as it became available, rather than perform a fresh install. The only remaining option is a fresh install.



  • Try this: type "vivaldi://flags/#enable-smooth-scrolling" without quotation marks into the address bar; and click "enable" on the yellow highlighted "smooth scrolling" option….
    Relaunch vivaldi for the changes to take effect....

    Hope that helped~ :)



  • Tests carried out:
    I shutdown Vivaldi, backed-up the user profile: 'Default' folder, then deleted the folder.
    Profile Path: C:\Users[username]\AppData\Local\Vivaldi\User Data\Default
    Restarted the browser, seeing no change in the scrolling behaviour.

    Then I uninstalled Vivaldi via the Control Panel and manually deleted all user data folders. Reinstalled with no change once again.

    This really appears to be a problem with the browser.



  • @werty8763:

    Try this: type "vivaldi://flags/#enable-smooth-scrolling" without quotation marks into the address bar; and click "enable" on the yellow highlighted "smooth scrolling" option….
    Relaunch vivaldi for the changes to take effect....

    Thanks, but unfortunately there is no change after trying the above. Scrolling is definitely more animated (smoother) with the 'Smooth Scrolling' option ticked in the normal settings, but nowhere completely smooth as in Firefox.



  • Well, unfortunately, there is nothing else I can do for you….. :(
    You could try the smooth scroll extension from the chrome web store, but I doubt it will work..... :dry:

    Feel free to ask any other questions; as for the smooth scrolling, I don't think I can help you..... :unsure:



  • Thanks for your suggestions, werty8763, I'll see how Vivaldi behaves on some other hardware. It's not a major issue, but if (and when) it gets corrected, it would certainly give the feeling of being a more polished browser.


  • Moderator

    @currentflow:

    Thanks for your suggestions, werty8763, I'll see how Vivaldi behaves on some other hardware. It's not a major issue, but if (and when) it gets corrected, it would certainly give the feeling of being a more polished browser.

    My smooth scrolling is smoooooth, at least as far as Chromium browsers go. I note that you said you're using Beta3 version, which is really ancient. It did not have smooth scrolling, really.

    Try the latest snapshot (here: https://vivaldi.net/ ) without any special settings. We are now at version 1.0.435.26.



  • Latest 1.0.435.40 version here, the 1st stable one and smooth scrolling has no effect. It's set in both settings and vivaldi://flags and it doesn't improve scrolling animation a bit. The setting has no effect. Isn't there really anybody else suffering from this issue?



  • @Atronach:

    Latest 1.0.435.40 version here, the 1st stable one and smooth scrolling has no effect. It's set in both settings and vivaldi://flags and it doesn't improve scrolling animation a bit. The setting has no effect. Isn't there really anybody else suffering from this issue?

    Same for me. I have tried Vivaldi on two computers and both have not so smooth scrolling with these little lags. It's annoying, switching back to Chrome.



  • I've also got Smooth Scrolling checked, but it doesn't seem to work. I'm on 1.0.435.42 () (32-bit) for Windows 10 Pro.



  • There are some changes in Vivaldi 1.2 (maybe it has changed before but i hadn't noticed. "enable-smooth-scrolling" flag with 2 options disappeared and now there's "smooth-scrolling" flag with 3 options. I've changed it from Default to Enabled and finally got smooth scrolling! I dont understand why the "Smooth Scrolling" checkbox in Settings > Webpages doesn't work while the functionality is there through vivaldi://flags…



  • Try this extension: https://chrome.google.com/webstore/detail/smoothscroll/nbokbjkabcmbfdlbddjidfmibcpneigj?hl=ru&gl=RU with these settings: https://i.imgur.com/DBZzj6p.png
    That way it should be as smooth as in Firefox at least.



  • Joseph Gylagstar: Why would I do that when i've finally gotten smooth scrolling to work with no need for a 3rd party app?



  • It's just a suggestion for you (and everybody else having the same problem) to try, nothing more.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.