Passwords dissapeared



  • Hello guys, i am using Vivaldi for a while and i really like it so far. But suddenly, today, all my saved passwords are gone and vivaldi is no longer asking for saving them. In settings i have checked "Offer to save your web passwords". Could you please help me? I dont wont to switch to different browser. Thank you for any advice. Karel



  • @kareldl:

    all my saved passwords are gone

    Do you see them at these addresses?

    vivaldi://chrome/settings/passwords
    

    vivaldi://settings/passwords

    @kareldl:
    
    > vivaldi is no longer asking for saving them. In settings i have checked "Offer to save your web passwords".
    
    Navigate to this, enter "password" in search box and check if the saving passwords in enabled from there.
    

    chrome://flags/

    @kareldl:
    
    > I dont wont to switch to different browser.
    
    At last resource, you could try to force import stored password from another browser: probably also with google chrome itself it'll work, or you can try to import in firefox by chrome, and in vivaldi by firefox)
    
    What vivaldi do you use? Beta or snapshot version?


  • Hi, thank you for your time! I appreciate it.

    1. Do you see them at these addresses? No, i dont.
    2. Yes, saving passwords is enabled.

    Importing passwords could be an option, but i would prefer Vivaldi to work properly.

    Currenty using
    Vivaldi 1.0.403.24 (Beta 3) (32-bit)
    Revision 0c0e1eb245235dfafc6a82065b23d3eaf464c8d1

    Thanks again.



  • @kareldl:

    Importing passwords could be an option, but i would prefer Vivaldi to work properly.

    If the password page is blank, maybe also the relative password file is empty: I think are the two "logindata" stored in c:\users\ <youruser>\appdata\local\vivaldi\userdata\default\

    If you have any other browser installed (expecially chrome), with the same passwords stored, probably the best choice is to try the import again in vivaldi.

    Can also install and try x64 vivaldi beta (if you have x64 system) or to run it as administrator (but I don't think is the problem).</youruser>



  • Hi, thanks again.

    I tried to import import passwords from other browsers and it works. But vivaldi still not asks if i want to save new passwords.

    Any advice?


  • Moderator

    @kareldl:

    Hi, thanks again.

    I tried to import import passwords from other browsers and it works. But vivaldi still not asks if i want to save new passwords.

    Any advice?

    If you go to chrome://settings/search#pass and look at the last entry on that search result, is the box offering to save passwords checked?



  • Yes, it is.

    And i have interesting update of this issue: when i restart Vivaldi, the passwords are back and vivaldi asks to save new passwords. But after a while (sometimes a minute), passwords are gone and vivaldi does not asks.

    Weird, right?



  • @kareldl:

    when i restart Vivaldi, the passwords are back and vivaldi asks to save new passwords. But after a while (sometimes a minute), passwords are gone and vivaldi does not asks.

    Do you have any extension installed? Try to disable them and see if the issue still happen.
    Try to disable also the legacy NPAPI plugins if there are any.
    You can also try to save current session when Vivaldi works (vivaldi button > file > save session) and reopen it (vivaldi button > file > open stored session) hoping this keep "the working state".
    However, the best choice is to export bookmarks (vivaldi button > file) if you need them, uninstall and reinstall vivaldi x64 (I suppose you have win x64) as administrator from the scratch installing in another folder (mine is in c:\vivaldi for example).



  • No extension, no plugin. Open stored session did not work. I will try the uninstall and reinstall and let you know. Thank you for helping.



  • So the uninstall and reinstall works. I hope it stays that way, really dont wont to do this often :)

    Thank you for helping!



  • I really think it was an isolate case. I'd some troubles with an old snapshot version, but now with newer snapshots and beta build I'm not facing particular issues like this :)



  • Just a suggestion: you might try using LastPass, an award-winning password manager that securely keeps track of your passwords; you don't have to worry about losing them or anything…. :)
    I've been using it for a long time, and I can guarantee that you won't be disappointed.... ;)
    Official Site: https://lastpass.com/
    You can also get it from the Chrome Web Store... :)


  • Moderator

    Not all people trust foreign servers to store their passwords securely.
    A local password store like KeePass2 and ChromeIPass would be better then.



  • Strongly agree re KeePass2 – it's excellent AND stays local [works great in Win & Linux]. I do use V to store some convenient non-critical passwords, but for all financial or especially personal sites, all those passwords are in KP only, not V [or any other browser].

    Just on the original issue of the disappearing / reappearing V passwords nuisance, whilst they've been very reliable for me now for many many SS's, in the much earlier V days (i have used it since 7/Feb/15] they would vanish one SS, reappear the next SS [or the one after], vanish the next, reappear again later… it made my head spin in amazed exasperation. However for me at least [Linux user] they have been very stable for a long time now.

    Good luck!



  • Disappearing passwords is present again on the last two snapshot. (at least on my windows).
    Filled a bug linking this thread, VB-14913 :)


  • Moderator

    Yes, i say your report in bugtracker.
    But sadly i cant reproduce such problem with 1.0.435.29 x64 on Windows 10x64.

    I can see all my passwords stay in vivaldi://settings/privacy/
    Even after minutes of browsing.

    May be a security software on your system blocks the password database file?
    Do you have a special Vivaldi installation or Windows insider version?
    Can you please test the integrity of you harddisk with chkdsk?



  • The hard disk is pretty new (few months, internal), but I'll do a test soon.
    I'll try install new snapshot in another directory.
    Another strange thing: opening Vivaldi, this morning, said "my profile is corrupted", and in the first minute which password manager worked, it prompts for my windows logon password for some of them (which is strange, some others, are visible simpling click "show" button).
    All icons of the bookmarks were blank. After Vivaldi restart (in this case force close of all Vivaldi.exe) they returned.
    I use Panda as AV (never said anything related Vivaldi) and Win10 firewall control (GUI of Windows firewall, all traffic enabled for Vivaldi.exe, not only browser zone).
    Re-importing data from "old" Vivaldi profile didn't work (probably as profile is corrupted)
    Re-importing bookmarks from html file of the same "old" profile, worked
    Passwords restored by firefox profile
    History of Vivaldi wasn't recovered, but is not so important xD
    I'll test for a while without extensions ^^



  • Re-importing data from "old" Vivaldi profile didn't work (probably as profile is corrupted)
    Re-importing bookmarks from html file of the same "old" profile, worked
    Passwords restored by firefox profile
    History of Vivaldi wasn't recovered

    You can just copy the old one in the new profile.

    In my exerience all the files inside the "default" folder, minus the subvolders can be copied safely, usually any major corruption resides in the dbs inside the subfolders.



  • Yes, but I hadn't important changes, so I opted for a whole new profile.
    I don't think to have big major corruption as the old profile still works, except for password issue.



  • Hi,

    I don't believe it is an isolated case, as it has happened to me as well. I'm currently sitting at 1.0.435.42 () (32-bit) @ Win7 Pro 64.

    I wasn't installing any snapshots so far, only official releases (alphas, betas, and finals). I could swear that it started when the final came up (the first one).

    I'm not in the mood to reinstall/clean profile yet, I just wanted to let you guys know, that is is not a singular case :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.