Do the default browser doesn't work

  • In Linux and Windows either. In Linux doesn't do anything and in Windows the OS reverts the default browser and doesn't save it.

  • Making Vivaldi my default browser does not work. I have been using Chrome as my default on my Windows 10 machine. When I try to make Vivaldi my default browser it reverts to Microsoft Edge even though I have told it to make Vivaldi my default. What is up?

  • Moderator

    I suspect your are using Beta 3 or earlier. Since then the "default" bug has been fixed in snapshots

    That said, you can to into the Windows Control Panel "Default Programs" and set Vivaldi to have all of its defaults. At that point, Vivaldi will be your default browser. I did that months ago, and it has been my default browser ever since. When windows updated and force-converted my default back to Edge (along with reverting my default photo program, my default word processor, my default pdf viewer, etc.) I simple used the control panel to re-assign all defaults to Vivaldi.

  • :) :) Thanks so much. Works great now as my Default browser. Also amazed that Roboform works within Vivaldi, albeit with a very slight difference from Chrome.

  • As this is the Linux stream, as the OP asked about both Linux & Win, & as there seems to be no other replies explicit to Linux herein, i offer this relevant link for the OP, fyi:

  • I have been having the same problem for a while now, running Vivaldi in Kubuntu 16.04.
    After updating to Vivaldi 1.3.551.30 (Stable channel) (64-bit) I cannot set it as my default browser again.
    I tried the methods listed in other threads like setting it as default browser via KDE System Settings > Applications > Default Applications > Web Browser and setting vavaldi-stable as my default browser, but I am still getting this "Default browser" dialog everytime I start Vivaldi. Any other ideas on how to fix it? It is clearly a bug. :(

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.